Skip to main content
gsharma
Staff
Staff
September 22, 2026

Technical Tip: Scripting support for HTTP2 backend

  • September 22, 2026
  • 0 replies
  • 16 views

Description

This article describes the error 'HTTP2 enabled VS does not support scripting'.

Scope

FortiADC.

Solution

The Scripting module provides tools for using Lua scripts with HTTP/HTTPS virtual servers, as well as Layer 7 TCP and UDP virtual servers. These scripts can be used to implement custom actions or processing that are not available through FortiADC’s standard built-in features, such as encrypting insert cookie.

Types of scripts:

  • HTTP scripts.

  • Stream scripts.


The server in the backend can sometimes support the HTTP2. For that, HTTP2 has to be enabled in the HTTP2 profile under Application Resources, as it is disabled by default.

To configure the HTTP2 profile, refer to this document: Configuring HTTP2 profiles

After enabling backend HTTP2, if the scripting profile is called, then there will be an error to save this configuration.


b698de25.png


This feature is currently disabled. For now, the workaround is to disable HTTP2 backend feature in case scripting needs to be enabled for this Virtual Server.

Thought Leadership. Security Summit. Thursday, November 12th, PGA National Resort, Palm Beach Gardens, FL.
Thought Leadership. Security Summit. Thursday, October 8th. Disney's Grand Californian Hotel & SPA, Anaheim, CA.