Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
New Contributor

FortiClient VPN Problems With OSX 10.11 El Capitan

I installed the GM candidate of Mac OS X 10.11 El Capitan and my FortiClient VPN has stopped working. It completes the login, but after connection, no data is transferred - the incoming and outgoing freeze. It is a split tunnel connection and neither network or internet traffic works. 


I tried disabling the firewall and System Integrity Protection, but neither had any effect. 

9 Solutions
New Contributor II

I've been trying since the first public beta, and now on the final GM Candidate. The VPN problem is there. Basically, what is wrong is that OS X's resolver is sending traffic out through the primary (original) network interface, even though the route table correctly shows that the VPN tunnel (ppp0) should be used.


When you use a command like nslookup, the DNS traffic goes through the VPN tunnel (ppp0) properly.


DNS name resolution  fails because my VPN client is told to use my corporate DNS server, but my corporate DNS server refuses to serve name queries from outside the corporate network. When the FortiClient VPN is connected, OS X's name resolution traffic arrives at the DNS server with the client's public Internet IP address, and hence is refused by my DNS server.


Technically, this looks like an OS X bug. Or, perhaps there really is something wrong that FortiClient is dong. Either way, I hope FortiNet can rectify or take it up with Apple to fix El Capitan.

View solution in original post

New Contributor III

Facing the same issue. Latest FortiClient(5.3*) did not fix it.

But, FortiClient 4.0.2082 did not have any such issues(though it occasionally stops tunneling on its own).


Waiting for a fix like everyone, but 4.0.2082 is letting me work for time being.

View solution in original post


I've gotten it to "work" by getting the DNS to use ppp0 and some route magic. Explanation is on:


Let's hope either party fixes this, because running scripts after establishing VPN is quite cumbersome.

View solution in original post


Chris.Lin wrote:

There is a new private build here:


Would you guys give it a try?

It works for now! Thanks!

View solution in original post


Just ran El Capitan updates and it still does not work - bummer

View solution in original post


Chris.Lin wrote:

Here is another interim build b499.


5.4.1 release may be available at the end of February.


P.S. b493 from previous post is different from the official 5.4.0 b493. Developer made the change after 5.4.0 was released.

Thanks ! I had same problems that other people since 3 months with forticlient and this new build fixes the issue!!! Great job!

View solution in original post


After update to MacOS Sierra the client 5.4.1 works as expected.... 

View solution in original post

148 REPLIES 148

For me, I have downgraded back to Yosemite via Time Machine (Cmd+R at boot) because I need FortiClient in my daily work. In Yosemite, everything with FortiClient works fine.


The resolver issue in Mac OS X 10.11 can be verified without VPN:


For example if you have two network cards (LAN and WIFI), you manually add a route to the DNS server through the non primary interface, "ping" will generate DNS traffic through the non primary interface (correct), however the source IP of the packet will still be the primary interface (incorrect), thus no reply will come back.


Are you saying it can't/won't be fixed until Apple provides a fix?


Couldn't this also be fixed by changing Fortinet to have the VPN show up as an adapter in the Network configuration (then a user can just change the dns easily)?

New Contributor III

I get the below crash quite often. I was of an assumption that it was due to El Capitan, but upon looking into the dump trace, I see its because of Fortinet. Anyone else having this issue?


Anonymous UUID: E140DDC2-C2B4-3072-FB84-FD286608ECDB
Sat Oct 10 07:41:13 2015
*** Panic Report ***
panic(cpu 2 caller 0xffffff8016dd6a9a): Kernel trap at 0xffffff801704ccac, type 13=general protection, registers:
CR0: 0x000000008001003b, CR2: 0x0000209b81023000, CR3: 0x000000001a463000, CR4: 0x00000000001627e0
RAX: 0xdeadbeefdeadbeef, RBX: 0xffffff8037052630, RCX: 0xffffffffe856dc50, RDX: 0x0000000000000001
RSP: 0xffffff82009b3900, RBP: 0xffffff82009b3980, RSI: 0x0000000000000002, RDI: 0xffffff8036d49f80
R8: 0xffffff8036d47000, R9: 0xffffff804fbb47e0, R10: 0x0000000000000238, R11: 0xffffff81f8da9fbc
R12: 0xffffff804fbb41c0, R13: 0x0000000000000001, R14: 0xffffff804fbb47e0, R15: 0xffffff80370521a8
RFL: 0x0000000000010282, RIP: 0xffffff801704ccac, CS: 0x0000000000000008, SS: 0x0000000000000010
Fault CR2: 0x0000209b81023000, Error code: 0x0000000000000000, Fault CPU: 0x2, PL: 0
Backtrace (CPU 2), Frame : Return Address
0xffffff81f7055df0 : 0xffffff8016ce5357
0xffffff81f7055e70 : 0xffffff8016dd6a9a
0xffffff81f7056050 : 0xffffff8016df4093
0xffffff81f7056070 : 0xffffff801704ccac
0xffffff82009b3980 : 0xffffff80170499f8
0xffffff82009b3d90 : 0xffffff80170363d7
0xffffff82009b3de0 : 0xffffff8017037913
0xffffff82009b3f40 : 0xffffff8016f6d58c
0xffffff82009b3fb0 : 0xffffff8016dd14b7
BSD process name corresponding to current thread: kernel_task
Boot args: kext-dev-mode=1
Mac OS version:
Kernel version:
Darwin Kernel Version 15.0.0: Wed Aug 26 16:57:32 PDT 2015; root:xnu-3247.1.106~1/RELEASE_X86_64
Kernel UUID: 37BC582F-8BF4-3F65-AFBB-ECF792060C68
Kernel slide: 0x0000000016a00000
Kernel text base: 0xffffff8016c00000
__HIB text base: 0xffffff8016b00000
System model name: MacBookPro11,3 (Mac-2BD1B31983FE1663)
System uptime in nanoseconds: 3124454776600
last loaded kext at 25524518244: com.fortinet.fct.kext.fctapnke 1 (addr 0xffffff7f99c6b000, size 401408)
last unloaded kext at 1354301372607: 3 (addr 0xffffff7f9920c000, size 40960)
loaded kexts:
com.fortinet.fct.kext.fctapnke 1
com.kaspersky.kext.klif 3.0.2a239 124 1.9.5d0 1.70 3.0 110.20.19 2.5.1d0 1.0.0 1 3.7.7 272.50 1 1.0.1 3.6.1 4.4.0f4 7.0.0 10.0.6 10.0.8 1 1.2.13 4.4.0f4 4.0.0 208 10.0.8 3.1 5.41.0 3.11.31 3.0.8 3.7.1 245.4 245.4 1.0.0d1 1.0.0 37 2.8.0 3.1.5 1000.13.1a3 161.0.0 4.0 2.0 1.8 2.1 4.0 1.7 163 3 8 1.0 272.50 525 11 10.0.6 10.0.6 1 108.0.1 1.0.14d1 4.4.0f4 4.4.0f4 272.50 272.50 203.8 1.2.0 1.0.0 3.11.31 203.7.1 1.1.0 2.4.1 3.11.31 2.4.1 1.0.0 3.1.9 6.0.0d7 3.7.7 1.0.0 3.7.7 250.4 900.4.1 1.0.1 1.0.1 517 2.8.0 4.1.2 4.1.2 2.0.2 4.0.1 5.0.6 1100.23 1.0.1b8 3.2 1.0.4 1.0.1 1.0.1 900.4.1 1.0.1 1.0.1 2.0 2.0 2.0.0 1.1 300.0 1.0.0d1 2 1.0.5 1.0 414 2.1 31 28.30 4.0 2.9 1.4 1 1 1.0
Model: MacBookPro11,3, BootROM MBP112.0138.B15, 4 processors, Intel Core i7, 2.3 GHz, 16 GB, SMC 2.19f12
Graphics: Intel Iris Pro, Intel Iris Pro, Built-In
Graphics: NVIDIA GeForce GT 750M, NVIDIA GeForce GT 750M, PCIe, 2048 MB
Memory Module: BANK 0/DIMM0, 8 GB, DDR3, 1600 MHz, 0x02FE, -
Memory Module: BANK 1/DIMM0, 8 GB, DDR3, 1600 MHz, 0x02FE, -
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x134), Broadcom BCM43xx 1.0 (
Bluetooth: Version 4.4.0f4 16320, 3 services, 19 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en0
Serial ATA Device: APPLE SSD SM0512F, 500.28 GB
USB Device: USB 3.0 Bus
USB Device: Apple Internal Keyboard / Trackpad
USB Device: BRCM20702 Hub
USB Device: Bluetooth USB Host Controller
Thunderbolt Bus: MacBook Pro, Apple Inc., 17.1
New Contributor II

Tonight FortiClient 5.4 was released, which supports El Capitan. Give it a try.


Anyway the DNS problem still exists, as you can see in the release notes, because it is an Apple problem. 

Peter Bruderer
__Peter Bruderer
New Contributor

Thanks for the update. The release notes here mention a workaround for the DNS problem:

"use a public DNS, so that all DNS traffic goes through the public interface"

Can you explain how you would do that? Any response from Apple yet?

New Contributor III

brudy wrote:

Tonight FortiClient 5.4 was released, which supports El Capitan. Give it a try.


Anyway the DNS problem still exists, as you can see in the release notes, because it is an Apple problem. 

Would you mind linking it here? I am not able to find 5.4 anywhere.

Thanks in advance.

New Contributor

I am having the same issue, everything worked perfect yesterday. Updated to El Capiton and now when I connect the VPN I loose connection to everything except the network I am connected to through the VPN. Is there any update when this issue will be resolved. 

New Contributor

Any solutions to this?



I'm having the same issue.  Quite annoying.   Hopefully a solution will be available shortly.


Select Forum Responses to become Knowledge Articles!

Select the “Nominate to Knowledge Base” button to recommend a forum post to become a knowledge article.

Top Kudoed Authors