Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
New Contributor

Can't uninstall FortiClient Mac Monterey

Sorry if this is a repeat topic, but I haven't seen an answer that works for me.

I can't uninstall FortiClient-VPN-only from Mac OS X Monterey.  Both the application and uninstaller are locked, and I can't unlock them (I've worked with Apple for hours, updating disk permissions, safe boot, command line inputs, etc.). The uninstaller also won't load, saying "You can’t open the application “” because it may be damaged or incomplete." This happens even following a clean reinstall.  


As this product isn't tech-supported, I went into the knowledgebase which simply says "The EMS administrator may deploy uninstall to managed FortiClient (macOS) endpoints."  I didn't install EMS, as this is not a managed system.


So what now? Any suggestions would be much appreciated.


Hi Brillo, 


Could you please try this to see if it helps you remove FCT from that machine:


Before running uninstaller make sure you shutdown Forticlient completely.

-To shutdown, right-click on FortiClient icon, select 'shutdown' from menu.

-Uninstall vial unintaller in Applications folder.

The last solution is to Delete MacOS Fortinet or FortiClient references manually:




If none of them worked, as an alternate: (Forced uninstall)

-Open Applications > Utilities > Terminal

-Mac$ cd /

-Mac$ cd Library/LaunchDaemons

-Mac$ sudo rm -rf com.fortinet.forticlient.*

-Mac$ cd /

-Mac$ cd "Library/Application Support/Fortinet"

-Mac$ sudo rm -R FortiClient

-Reboot Computer

Pedro Valente
New Contributor


I have the same problem. I received a new MacBook Pro yesterday, so I transferred the content of my old MacBook to the new one. Now it is impossible to remove, install or uninstall Fortinet. Here is what happened:

- I made a backup of the old MacBook (running OS Monterey 12.4) with TimeMachine

- I used OSX Migration Assistant on the new MacBook (running OS Monterey 12.4), to transfer the TimeMachine backup

- At the end, there was an error message, saying that some data related to FortiClient and FortiClientUninstaller could not be transferred

- Now, on the new MacBook, I have both FortiClient and FortiClientUninstaller files in the application folder that a) have a size of zero b) are locked, impossible to unlock, impossible to delete.

I've tried various things, including the above command, but nothing works.

Thanks a lot if anyone has any advice on what to do.

Best regards,