Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
Brillo
New Contributor

Can't uninstall FortiClient Mac Monterey

Sorry if this is a repeat topic, but I haven't seen an answer that works for me.

I can't uninstall FortiClient-VPN-only from Mac OS X Monterey.  Both the application and uninstaller are locked, and I can't unlock them (I've worked with Apple for hours, updating disk permissions, safe boot, command line inputs, etc.). The uninstaller also won't load, saying "You can’t open the application “FortiClientUninstaller.app” because it may be damaged or incomplete." This happens even following a clean reinstall.  

 

As this product isn't tech-supported, I went into the knowledgebase which simply says "The EMS administrator may deploy uninstall to managed FortiClient (macOS) endpoints."  I didn't install EMS, as this is not a managed system.

 

So what now? Any suggestions would be much appreciated.

7 REPLIES 7
pvalente
Staff
Staff

Hi Brillo, 

 

Could you please try this to see if it helps you remove FCT from that machine:

 

Before running uninstaller make sure you shutdown Forticlient completely.

-To shutdown, right-click on FortiClient icon, select 'shutdown' from menu.

-Uninstall vial unintaller in Applications folder.

The last solution is to Delete MacOS Fortinet or FortiClient references manually:

 

 

 

If none of them worked, as an alternate: (Forced uninstall)

-Open Applications > Utilities > Terminal

-Mac$ cd /

-Mac$ cd Library/LaunchDaemons

-Mac$ sudo rm -rf com.fortinet.forticlient.*

-Mac$ cd /

-Mac$ cd "Library/Application Support/Fortinet"

-Mac$ sudo rm -R FortiClient

-Reboot Computer

Pedro Valente
basile
New Contributor

Hello,

I have the same problem. I received a new MacBook Pro yesterday, so I transferred the content of my old MacBook to the new one. Now it is impossible to remove, install or uninstall Fortinet. Here is what happened:

- I made a backup of the old MacBook (running OS Monterey 12.4) with TimeMachine

- I used OSX Migration Assistant on the new MacBook (running OS Monterey 12.4), to transfer the TimeMachine backup

- At the end, there was an error message, saying that some data related to FortiClient and FortiClientUninstaller could not be transferred

- Now, on the new MacBook, I have both FortiClient and FortiClientUninstaller files in the application folder that a) have a size of zero b) are locked, impossible to unlock, impossible to delete.

I've tried various things, including the above command, but nothing works.

Thanks a lot if anyone has any advice on what to do.

Best regards,

Basile

ebarronh
New Contributor

Any new about this? I'm still not able to uninstall Fortinet. Same as @basil.

I really regret installing this.

 

Screenshot 2023-09-09 at 10.27.45 AM.png

EB
EB
maulishshah
Staff
Staff

Hi @Brillo@ebarronh

 

Can you please try below steps if it will help you to uninstall 

 

1) In the support portal, go to Support -> Firmware download -> FortiClient -> Select the corresponding version -> FortiClientTools_[version].zip.

2) Unzip the file and run the <FCRemover> tool to remove FortiClient.

Maulish Shah
Brillo

Thanks but I can't find this file (or I have the wrong site). Please send the exact URL to reach the firmware download page. Thank  you.

maulishshah

@Brillo, the URL is support.fortinet.com 

 

Please select FortiClient from the downloads, and then follow these steps

 

Here I am attaching images in sequences Please verify

 

Once you reach the corresponding version, please download the 

FortiClientTools_xxxxxx_macosx.tar.gz

 

Extract it, and then please run the remove file from the folder and see if that works. 

 

 

 

 

Maulish Shah
hbac
Staff
Staff

Hi @Brillo

 

Have you tried each method from this article: https://community.fortinet.com/t5/FortiGate/Technical-Tip-How-to-uninstall-FortiClient-on-macOS/ta-p...

 

Regards, 

Announcements

Select Forum Responses to become Knowledge Articles!

Select the “Nominate to Knowledge Base” button to recommend a forum post to become a knowledge article.

Labels
Top Kudoed Authors