Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
Akmostafa
New Contributor II

manual Fortilink and custom commands

Hello Team,

I have an FG on 7.0.7 and two swithces 108E-FPOE and 148E both on the compatible 6.4.4.

 

In a specfici scanarion I needed to disable the automatic forming of Fortilink trunk between the switches especially that there are 3rd party network devices in between them.

 

I did asigned the default lldp profile (with no auto-isl ) to the uplink ports and set the AC discovery on the 148E to static, and configured the trunk manually 

conf switch trunk

edit trunkname

set member xx

end

end

config switch interface

edit trunkname

set allowed vlans .....

end

end

However, whenever the switch is connected to Fortigate all this is overriden by the default automatic trunk.

 

I even tried to configure my custom settings using a custom command (forcing my desired allowed and native VLANs on the uplinks). 

The custom commands do successfully apply to the 108 switch.

On the other switch the custom commands are applied to the switch then they are overridden again with the vlan configurations configured on Fortigate (I noted this by the diag debug cli 8 on the Fortiswitch cli).

 

My desired scenario is that the native vlan needed to be 1 not 4094.

 

All my trials fail to achieve this.

 

It only worked when I changed the mgmt vlan to 1 using the below commands on the switches

config switch interface

edit internal 

set native-vlan 1

end

end

 

2 REPLIES 2
Anthony_E
Community Manager
Community Manager

Hello Akmostafa,


Thank you for using the Community Forum. I will seek to get you an answer or help. We will reply to this thread with an update as soon as possible.


Thanks,

Anthony-Fortinet Community Team.
ebilcari
Staff
Staff

Some information is covered in the admin guide here

by default in later version all ports are enabled to auto discover

config switch interface
edit "port1"
set auto-discovery-fortilink enable

remove the auto discovery on port level for one or both switches:

# set auto-discovery-fortilink disable

and change the LLDP profile from "default-auto-isl" to "default" 

lldp.PNG

- Emirjon
If you have found a solution, please like and accept it to make it easily accessible for others.