I have some difficulties with a hub and spoke configuration. I have followed the Handbook examples on how to set up a hub and spoke network. The network consists of only 60c' s, all 4.0 MR2.
There' s one 60c at main and two remotes at the moment. I experience the problem at both remote locations and the configuration is almost identical.
Descritption of problem:
Remote sites can contact main site over IPSEC after establishing tunnel. The next time the tunnel is established, the remote site cannot contact main site over IPSEC tunnel. If I initiate communication from main, I am also able to establish communication from remote to main. This works until tunnel has to be re-initiated, then the same thing happens.
From what I' ve been able to gather from diagnostics through CLI, the remotes seems to pass traffic to main through IPSEC tunnel interface, but I can' t see any replies from main.
It' s a bit like this guy' s problem, only his configuration differs a little: http://support.fortinet.com/forum/tm.asp?m=68738&p=1&tmode=1&smode=1
Routing table remote site:
S* 0.0.0.0/0 [10/0] via 212.33.132.241, wan1, [0/50]
S 192.168.0.0/24 [10/0] is directly connected, toHub
C 192.168.2.0/24 is directly connected, internal1
C 212.33.132.240/30 is directly connected, wan1
Routing table main site:
S* 0.0.0.0/0 [10/0] via 77.241.103.13, wan1, [0/50]
C 77.241.103.12/30 is directly connected, wan1
C 192.168.0.0/24 is directly connected, internal
S 192.168.2.0/24 [1/0] is directly connected, toSpokes_0
Remote site IPSEC Ph1:
config vpn ipsec phase1-interface
edit " toHub"
set interface " wan1"
set proposal 3des-sha1 aes128-sha1
set remote-gw 77.241.103.14
set psksecret ENC 7s2wTnNbvhLXXyhlY673G6JS2pHlmdNkJ81WV5EGqZ222iLqNho18s/EY+FHCXCL/tlei4R46NI+3bQLtw81xJwdRCBFTOlUuwWKVpM/PU44Sy4H
next
end
Main site IPSEC Ph1:
config vpn ipsec phase1-interface
edit " toSpokes"
set type dynamic
set interface " wan1"
set proposal 3des-sha1 aes128-sha1
set psksecret ENC TG+HIeYCE8LEvnuPoqRgOe5P7Pbe/h05DSKDd7zBPbJt2SJwXVtblXrOw8pxA1+AOe7zVACCU0w0UGprWWjs070EdSdArDwtVyXbNL1n1kdsnF9s
next
end
Remote site IPSEC ph2:
config vpn ipsec phase2-interface
edit " toHub P2"
set phase1name " toHub"
set proposal 3des-sha1 aes128-sha1
set dst-subnet 192.168.0.0 255.255.0.0
set src-subnet 192.168.2.0 255.255.255.0
next
end
Main site IPSEC Ph2:
config vpn ipsec phase2-interface
edit " toSpokes P2"
set phase1name " toSpokes"
set proposal 3des-sha1 aes128-sha1
next
end
Firewall policies remote:
config firewall policy
edit 3
set srcintf " internal1"
set dstintf " wan1"
set srcaddr " Internal Net"
set dstaddr " all"
set action accept
set schedule " always"
set service " ANY"
set nat enable
next
edit 2
set srcintf " VPN Zone"
set dstintf " internal1"
set srcaddr " Spoke Net"
set dstaddr " Internal Net"
set action accept
set schedule " always"
set service " ANY"
next
edit 4
set srcintf " internal1"
set dstintf " VPN Zone"
set srcaddr " Internal Net"
set dstaddr " Spoke Net"
set action accept
set schedule " always"
set service " ANY"
next
edit 5
set srcintf " dmz"
set dstintf " wan1"
set srcaddr " all"
set dstaddr " all"
set action accept
set schedule " always"
set service " ANY"
set nat enable
next
edit 6
set srcintf " wan1"
set dstintf " internal1"
set srcaddr " all"
set dstaddr " Klient"
set action accept
set schedule " always"
set service " ANY"
next
end
Firewall policies main:
config firewall policy
edit 1
set srcintf " internal"
set dstintf " wan1"
set srcaddr " all"
set dstaddr " all"
set action accept
set schedule " always"
set service " ANY"
set nat enable
next
edit 2
set srcintf " wan1"
set dstintf " internal"
set srcaddr " all"
set dstaddr " Sofus Server"
set action accept
set schedule " always"
set service " RDP"
set nat enable
next
edit 3
set srcintf " VPN_Zone"
set dstintf " VPN_Zone"
set srcaddr " Spoke Net"
set dstaddr " Spoke Net"
set action accept
set schedule " always"
set service " ANY"
next
edit 4
set srcintf " VPN_Zone"
set dstintf " internal"
set srcaddr " Spoke Net"
set dstaddr " HK Nettverk"
set action accept
set schedule " always"
set service " ANY"
next
edit 5
set srcintf " internal"
set dstintf " VPN_Zone"
set srcaddr " HK Nettverk"
set dstaddr " Spoke Net"
set action accept
set schedule " always"
set service " ANY"
next
end