Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
New Contributor

Free FortiClient not saving password on Mac Monterey and FC 7.02



We have 2 users with a new macbook and both have Mac OS Monterey and Forticlient 7.02. Both are reporting that the password doesn't save when the "save password" box is checked. I saw in the documentation that this is a known issue when the "prompt for login" is enabled but they have the "save login" enabled in the connection settings and it doesn't seem to work there either. Anyone else have this issue? Is this a known issue? anybody got suggestions on how to solve this?




does this help?

- Toss a 'Like' to your fixxer, oh Valley of Plenty! and chose the solution, too00oo -
New Contributor II

Hey, did you fix the problem?

New Contributor

since multiple versions the same problem. Configuration seems correct. 

Multiple system don't have a problem. But some do have. Even freshly installed ones...


6.4.8 does work on the same macos client




I've had the exact same problem for a while now as well.


I'm depressed to see it'll never be fixed, and it is really basic feature, that's crazy on all official FortiClient VPN For Mac OS we've been hanging around for more than a year with the problem. Dev team are not aware ? I see many topics speaking about that. Release comes out but issue not fixed...


I have a MacBook Pro but I don't think it's hardware issue clearly, absolutely zero reason, that looks completely software end, I see so many people experiences same one on forum.


I'm have today with the latest version of Monterey 12.5.1.
And with FortiClient VPN I tried again and again the very latest version v7.0.6, I had 7.0.5 before, I tried a much older one and even the version suggested here v6.4.8. Are you sure by you is OK @Altoo_Chris ?


It unfortunately not work by me.


What is the problem ? The "Save password" feature is activated on the FortiGate for the connection. The box appears well after a first connection / disconnection.

You checked it check it and as soon as you disconnect password is not saved.
On FortiClient VPN Windows versions, it works on all versions.

What can be done to fix this issue for what should be a basic feature?

It's very painful when you connect to a lot of customers.


Hope bit help from one of you guys.


Thanks in advance!


Hi kev57rs3,


This is a known issue:


Free macOS FortiClient 7.0.7 will fix this, it should be released by this week if there is no delay.

New Contributor II

Hi btan,


I come back to you one week after.


And thank you for your so prompt feedback to my message, it is appreciable and important, I find that the team, a fortiori, is reactive. 

We trust on Fortinet and largely/widely use your products in our company. And need sometimes quick support.


I read here and there on your forums that it would be solved from version 7.0.3 of the paid FortiClient, I have tested, and use the VPN tab only for free like on Windows version if that was the case, and on it it works indeed!


This is a (long) known bug fixed but not on FortiClient VPN free version where everyone still has it. I assume that the fix to apply should be exactly the same than paid version...


In any case, on our side, we don't know how to do except wait, and we find ourselves blocked and in a hole, especially this tool is for my work in professional context.

I've been impatient for weeks if not months, I've checked every day since your notice and this morning still no 7.0.7 release in sight.

I have nothing to lose, I finish by try the latest version of the paid client with advanced features to see if it works. And it does!

On the FortiClient paid version, the password is correctly saved (v7.0.6.0208)! Just remain to fix it also on the similar free version.


To help you in future development, I would also like to point out two problems (especially an important and annoying one) that I noticed with previous versions of FC VPN macOS (free version):


- when you are connected, and use and work on the connection, the bytes remain close to zero while you download and send data (does not matters you'll tell me, but the indication is always interesting to know if it is correct)


- more important, as soon as you launch the client installation, and the package and script run, even before the Wizard finishes it, Private Relay (major iCloud+ feature) is disabled and no longer works at all. We have to uninstall the client to get it working normally again. And then receive immediately the notification that it is active.
There's something written and happening that Private Relay doesn't like :( You can use either one, which is very annoying. Are you aware of this bug?


That Private Relay deactivates when using the Forti VPN is conceivable and completely acceptable, but when the connection is closed, it should reactivate but here not it doesn't. As soon as we launch the installation of the client, is compromised. Only uninstalling FortiClient VPN fix the problem.

Both the paid and free version are impacted by these.


However, the Windows version works fine, they have the exact same design but the macOS version seems a bit less on point :(


Is this release of 7.0.7 version imminent pls?


Many thanks for your effort,


Capture d’écran 2022-08-29 à 09.31.42.png


Capture d’écran 2022-08-29 à 11.28.18.png


I'm exactly in the same situation. Just downloaded FortiClient VPN for macOS but I got version How can I get version 7.0.7 with the fix? Cc: @btan 


macOS FCT 7.0.7 free version VPN only can be found here:


It should be available in our official site soon.


Hi @kev57rs3 , I am not aware of Private Relay issue with FCT. If you have a EMS license, you can raise a technical support ticket for this.


Select Forum Responses to become Knowledge Articles!

Select the “Nominate to Knowledge Base” button to recommend a forum post to become a knowledge article.

Top Kudoed Authors