Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
New Contributor

Error 500: Internal Server Error

Hello,   Does anyone else have a problem on FortiOs 5.6 with Error 500: Internal Server Error?   Whatever setting I change (e.g change interface ip) I get error above when i click OK. The strange thing is also if I try to change ip over ssh cli i get disconnected and settings are not changed.   I have a  FortiGate-100D v5.6.0,build1449,170330 (GA)   Model name: FortiGate-100D ASIC version: CP8 ASIC SRAM: 64M CPU: Intel(R) Atom(TM) CPU D525 @ 1.80GHz Number of CPUs: 4 RAM: 3955 MB Compact Flash: 15331 MB /dev/sdb Hard disk: 30533 MB /dev/sda USB Flash: not available Network Card chipset: Fortinet 100D Ethernet Driver (rev.)   I tried to restart firewall but no luck.   Thanks for any info,   Gregor
Esteemed Contributor III

Will if your  change the ip_addr that your connection on I would expect a status.code 500 or disconnects


Have you ran any diag debug? Is the problem consistent without ANY changes ?


for the  webGUI status.code 500 I would try the following;

diag debug reset

diag debug enable

diag debug application  http -1


Than launch a browser at the  server process on what-ever port https://x.x.x.x:11443 for example and match or grep off  the output


e.g ( 403 )


( result==403)







New Contributor



The problem only occurs when i try to change something (IP address, enable SNMP, change DNS server and when click OK) I always the same error 500, otherwise  I can see web interface and settings normally.


diag debug does not produce anything...when i try to connect https://10.x.x.17:10443 and when i make a change.




I have the same issue on several of not all of the 80E's I manage (6).

Had the issue with 5.6.3 .4 and the new .5 (the last 3 firmware revisions anyway - might have gotten one of those numbers wrong).


Tried 3 browsers, at first I thought it was a local issue, and a different browser got me through the error on one of them. Have one now that I can't make a a change I need to. Started researching and found it's not a local issue, its a FW issue. This has been an ongoing problem for some time it seems. I saw a post where someone tweaked some log settings, didn't help me.


Very frustrating to say the least...


Check the crashlog for related processes which crashed in the past:

diagnose debug crashlog read

NSE 4/5/7

New Contributor

Good day 


I had the same issue. When I try and add a Policy, and click OK, I get the issue. I was using Chrome.

I then logged in with Internet Explorer, did the same steps and it was working fine then. My issue was Chrome


Ways to fix this issue-


Reload the page
The “HTTP Error 500” may be visible only for you, in case there was a brief connectivity problem. The website itself may be working fine, but you might have tried to access it when there was a momentary downtime, or your network failed to establish a connection to the website’s server.

Try reloading the page in the same browser with the Reload button or by pressing the keyboard shortcut Command+R for Mac, or F5 (Control+F5) for Windows.

If the website loads correctly, the issue was only temporary, and you can stop troubleshooting.

Clear your browser cache and cookies
When the website doesn’t open after reloading, your browser might be keeping expired or corrupted cache files and cookies. Reloading the page will not delete them, so you must clear them manually.

Read this guide on clearing cache and cookies in desktop browsers for detailed instructions.

Check these articles on deleting the cache on an Android phone or iPhone, if you use a mobile device.

Alternatively, you can test opening the page from another browser. For instance, if you use Chrome, try Firefox or vice versa.

After clearing the browser’s cache, reload the page to see if that solved the problem. If not, proceed with the next step.

Visit the website using another network
The connectivity problems causing the “HTTP 500 Error” may happen across your entire network. In this case, you will probably see the error on any device on this network.

To test if this is the problem, switch to another network. For instance, if you use a mobile phone connected to Wi-Fi, switch to mobile data.



Rachel Gomez