Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
New Contributor

Connected 148F Switch to Cisco 2960X - Traffic wont pass

Hi all,

I configured out of the box a 148F layer 2 fortiswitch and connected it to a Cisco 2960X layer 2 switch. From the Fortiswitch I can ping anywhere in the LAN, but if connect my computer or IP phone to the switch - nothing.


The computer and phone are on separate ports and in the correct vlan. The ports connecting the two switches are up and no errors. The switch has a L3 interface and it can ping its default gateway and as mention anywhere on the LAN. I just cant figure out why I'm not able to get anything on the computer and phone.

I'm new to Fortinet and have experience only with Cisco switches.

Thank you.


1 Solution

Is it possible you have native LAN mis-match? 

View solution in original post

New Contributor

Thank you for help on this. I didn't know that the native vlan on the access port its self had to be the native vlan of the data vlan. I didn't even know that access ports needed a native vlan on FSW. On Cisco the native vlan is set on the trunk (Link aggregation port).

New Contributor

Hi @tolinrome, I'm having the same issue. Can you please share some screen shots of the final config? This config is making me crazy.


Also @ebilcari, I'm having this error when I try to assign a different native vlan to the internal interface:

Native Vlan id cannot be same as system interface vlan. Conflicting SVI: VLAN-709 object set operator error, -56 discard the settingCommand fail. Return code -56


Thanks in advance.


the internal interface of the switch is for management, what are you trying to configure?


- Emirjon
If you have found a solution, please like and accept it to make it easily accessible for others.
New Contributor

Ok, solved. Was about the port speed in the Cisco. I adjust it in the FortiSwitch and everything worked.

- no Static Route needed.

- Access ports: config native VLAN only.

- "Trunk": config native VLAN (match with the Cisco one) and Allowed VLAN's.

- Every port like "Edge Port" and STP enabled.

- VLAN's created in System -> Interfaces -> VLAN.

New Contributor

This is my first time configuring a fortinet switch so, I really just made the native vlan on the access port the same as the native vlan of the data vlan I created.

New Contributor

Ok, then I supposed it worked just like that.

A last question, did you create a "Static Route" under the Router menu?


Select Forum Responses to become Knowledge Articles!

Select the “Nominate to Knowledge Base” button to recommend a forum post to become a knowledge article.

Top Kudoed Authors