Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
New Contributor II

Windows 11 22H2 update, FortiClient VPN doesn't work



Today I updated Windows 11 to the new version (22H2) on 2 PCs. FortiClient VPN worked seamlessly on the previous version (21H2) but after the update it doesn't connect and gives the following message:


Screenshot 2022-09-28 115237.png


Is it a known issue with FortiClient VPN? Is there a solution?


Thank you in advance,


New Contributor II

I removed and then installed the network card from device manager (plus I removed I think TAP Windows Adapter), removed/install Forticlient VPN and it worked




Windows 11 has been updated to a new version (22H2) which version is Forticlient for?


Hi Everyone. My issue is a little different in that my FortiClient shows that  it is connected, and I even get an IP address, but I cannot ping anything inside my network. I just get "PING: transmit failed. General failure." Here are screen grabs of my FortiClient and Windows versions:


Reinstalling FortiClient latest version and rebooting did not make any difference. If anyone have a fix it would be appreciated. I really do not want to reinstall everything form scratch.


I neglected to mention that it does the same, whether I am on Wi-Fi or LAN, so it is not a driver issue.


SAME ISSUE here.  Any word on a fix?

After upgrading to win11 22h2, forticlient will connect, but cannot ping or rdp into anything over the connected vpn.


I also uninstalled, reinstalled, removed network adapters, etc.  No luck.


I have the same issue as well. I was able to find a work around.


Once you connect to your VPN via Forticlient, on the main window it will tell you your assigned IP. Take note of that.


Go into your network adapters and find the Fortinet SSL Virtual Ethernet Adapter: 


Right-click, properties. 


Highlight  IPv4 and open properties.


Update the static IP with the one given in the Forticlient window.



It seems like the Forticlient software is not passing the IP over to the virtual adapter when connecting. Doing this manually will fix it. It's likely you'll have to do this each time you connect until there's a permanent fix.

New Contributor II

I confirm that this was successful as a temporary work-around.  Fortinet, please fix ASAP!


IMHO it's a windows issue.



Select Forum Responses to become Knowledge Articles!

Select the “Nominate to Knowledge Base” button to recommend a forum post to become a knowledge article.

Top Kudoed Authors