Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
New Contributor

FortiClient stuck at 98%

Hi All, since upgrading our 300C to FortiOS 5.2.6 we're experiencing problems (randomly) with incoming connection through FortiClient and FortiVPNSSL. The connection process goes well untill 98% and than stop without any error message or, in some other cases, connect and immediately disconnect.


The problem has been noticed on both Win7 and Win10 clients on different FGT models (300C, 300D and 400D), with different firmware (5.2.3 and 5.2.6) and different FortiClient versions (4.0.2300 and 4.0.2323).


Fortinet support provided a FortiClient version ( to be tested => no success; then a "fix" for a similar problem observed on Win8 (even if we don't use this) found at => no success.


It also happen often that, after a succesful connection, the client is not able to connet anymore using both che vpn client and the web access. Sometimes a restart fix the issue, sometimw a vpn client reinstall fix the issue, sometimes nothing of these have effect...


What really make me think about some bug or, at least, some communication issue between the vpn client and the FGT is taht a restart of the process vpnssld on the FGTsolve temporarely the issue and everything start working as expected... until the problem show up again after a couple of days. It looks like some "communication" issue cause the vpn deamon to "hang" for that particular user (while others are able to connect in the meanwhile).


Did anyone experienced such an issue?


Thanks in advance



FGT: 50E,100D, 200D, 600D


FGT: 50E,100D, 200D, 600DFMG: VM64 FAZ: VM64
New Contributor



We are still experiencing this problem with FortiClient version under Windows 10 (64bit).

(never had this under Windows 7)


After deinstalling the client, reboot, and install again the problem is solved for a couple of days.

Then the same issue re-appears.


Is there a deffinite solution for this problem?





for us the solution was to upgrade to 5.2.7 as this firmware version seems to solve the problem. Our ticket by TAC is still opened (from February) but Fortinet engineer hasn't provided any working solution yet and still say that the problem is due to some "conflict" on the client endpoint. What can I say... in my opinion a problem like this cannot be left hanging around for so long without a solution and I told them this. The answer was that "'s not predictable how much time is requested for fixing an issue.." so, in the end, the customer has just to wait and survive..

Not a seriuos approach in my opinion but that's it!



FGT: 50E,100D, 200D, 600D


FGT: 50E,100D, 200D, 600DFMG: VM64 FAZ: VM64

We get this issue from time to time. The solutions have been one of the following:


-Upgrade FortiClient version

-Upgrade FortiGate Firmware

-Reboot computer

-Reboot firewall

-Uninstall forticlient and reinstall


For some reason each of these has worked when the others haven't depending on the fortigate or the situation. I have not been able to pin point the specific causes for each being the solution though :(

Mike Pruett Fortinet GURU | Fortinet Training Videos

Hi, a had same problem with Windows 10 Enterprise and Forticlient SSL VPN...

my solution:

New Contributor

Uncheck IPv6 from your network properties on all your interfaces and then reboot your PC.


I was just getting reports of some of my users having the 98% stuck bug as well over the past few days using SSLVPN.

For reference the setup in question is a Fortigate 60E running firmware 5.4.4

Forticlient version running on Win 10 Pro build 1607

System connected to a wifi network at a remote location.


I was seeing the following on the Forticlient log exports (with default Info log-verbosity):


4/26/2017 2:25:49 PM Error VPN FortiSslvpn: 6300: Ras : connection to fortissl failed : 6:0:0: 4/26/2017 2:25:56 PM Notice VPN Unable to establish the VPN connection.(E=98,T70,M99,R-983070010) 4/26/2017 3:25:36 PM Notice VPN FortiSslvpn: 10860: fortissl_connect: device=fortissl 4/26/2017 3:25:38 PM Error VPN FortiSslvpn: 11260: Ras : connection to fortissl failed : 6:0:0: 4/26/2017 3:25:47 PM Notice VPN Unable to establish the VPN connection.(E=98,T70,M99,R-983070010) 4/27/2017 9:17:31 AM Notice VPN FortiSslvpn: 12124: fortissl_connect: device=fortissl 4/27/2017 9:17:33 AM Error VPN FortiSslvpn: 13076: Ras : connection to fortissl failed : 6:0:0: 4/27/2017 9:17:42 AM Notice VPN Unable to establish the VPN connection.(E=98,T70,M99,R-983070010)


Reinstalling, repairing, rebooting did not fix. I tried connecting the client to other Fortigate devices I manage on other firmware versions and other networks unsuccessfully. I called Fortinet support and they have a 5.6 beta 2 version they provided me. Support mentioned that there is some type of bug or issue with some of the "SSL" drivers bundled with Forticlient (Support's own words) that weren't playing nice on Win 10.


I installed the Forticlient 5.6 beta 2 client on a particular workstation (uninstall 5.4 Forticlient via Programs/Features, reboot, install 5.6 beta 2, reboot) and was able to connect successfully to my VPN.


Support says that GA may be in May for 5.6 - but you should be able to open a ticket and get the 5.6 beta from them if you are having similar issues.

New Contributor

Still got the same error with version

What helped for me is un-installing the WAN Miniport (IP) driver in the Device Manager under Network adapters.

Reboot your Desktop/Laptop.




Upgrade to Forticlient 5.6 will fix this issue...



Regards, Paulo Raponi

Regards, Paulo Raponi
Top Kudoed Authors