Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
Jannik
New Contributor

FAP-431F with LACP on FSW-M426E-FPOE not booting

Hi,

 

I have FortiAP 431F connected to a FortISwitch M426E. I connected the 2.5Gbps Port of the FortiAP to a 2.5Gbps Port on the Switch and the 1Gbps Port of the AP to a 1Gbps Port on the Switch. I configured an active LACP Trunk on the Switch and set the FortiAP WANLAN_Mode to AGGREGATE. When I reboot the AP it wont come up. Only until i disconnect on of the Ports. Then it boots correctly and I can add the second connection back. What could cause this behaviour? I tried this on an ExtremeNetworks x440 PoE Switch and the reboot worked perfectly as expected. Only difference is both ports were 1Gbps. Is there a known BUG with LACP and 1Gbps+2.5Gbps? Any ideas?

 

4 REPLIES 4
adambomb1219
Contributor III

Are you sure you can use both interfaces at once?  I'm willing to bet if the 2.5gbps interface comes up at 2.5gbps it disables the 1gbps interface.  

ebilcari
Staff
Staff

LACP will not support different speed on the port members, this is a protocol limit. Usually the interface should downgrade to lower speed or you can manually set the speed in the (2.5Gbps) port to 1Gbps in order for the LACP to form. Basically you will get less BW in total (2Gbps) but you gain redundancy in case of link failure.

- Emirjon
If you have found a solution, please like and accept it to make it easily accessible for others.
Jannik

Hi, thanks for your replies. I had LACPs configured with multiple port speeds in the past and it worked fine. I think I found the problem in the logs. I created the LACP for both ports and disabled STP. When the AP boots I can see in the logs "primary port 04-04 instance 0 changed state from forwarding to discarding" - so the swith does STP eventhough I disabled it. I deleted the LACP and had the seperate ports again. I disabled STP on both ports, then formed that LACP. STP was enabled on the LACP by default. I disabled it again and it still does STP. Seems like a bug to me but maybe I missed something? Maybe its just a GUI bug, I could try to do these settings via CLI.

Jannik

I just checked the config via CLI and the ports dont show any stp options while the LACP shows stp-state: disable.

Labels
Top Kudoed Authors