Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
Not applicable

DHCP not passing dns to client

FG-60 as dhcp server. Wan1 gets static IP from ISP via DHCP. System ->Network ->Wan1 shows " Acquired DNS: " Yet when I release and renew on my client pc, it is still retaining old values from previous experimentation (Level3' s) I have confirmed I do not have these Level3 values anywhere else on the FG, nor statically coded to the client. Have rebooted the FG and the clients, released/renewed same thing.
Valued Contributor III

Fortigates aren' t DNS servers, but can be used to proxy DNS requests (I believe). The PC has to be set to use the FGT as it' s DNS source. It won' t be picked up by the PC automatically. Personally, I use Linux DNS services and leave the FGT to route, and scan. That' s what it' s built for. Make sure you add DNS entries into the DHCP configuration in the FGT. Also run an ' IPCONFIG /FLUSHDNS' from the command prompt to clear out any artifacts that may be left over from the old DHCP configuration. ' IPCONFIG /RENEW' may take care of this as well.

Bob - self proclaimed posting junkie!
See my Fortigate related scripts at:

Bob - self proclaimed posting junkie!See my Fortigate related scripts at:

If you use DHCP server for any interface, configure DNS settings (and WINS, etc) in DHCP server configuration for that iface (your own servers or isp dns servers) ISP' s acquired DNS servers are not automagically translated to internal dhcp leases.


/ Abel

regards / Abel

Select Forum Responses to become Knowledge Articles!

Select the “Nominate to Knowledge Base” button to recommend a forum post to become a knowledge article.

Top Kudoed Authors