Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
bmduncan34
New Contributor III

Building VPC between FortiSwitches (MCLAG/ICL) and Cisco Nexus 9K Switches

I'm trying to bring up a trunk over a port-channel between a pair of 1048E's and a pair of Cisco 9504's that are configured using vPC.  One fibre connects one 1048 to one 9504, and the other fibre connects the other 1048 to the other 9504.  The VPC on the Cisco side fails, saying "vpc port channel mis-config due to vpc links in the 2 switches connected to different partners".  I am working with support and Cisco support, but I wanted to ask if others have gotten this working.  We're looking at possible spanning-tree issues, but also best practice guides on the Cisco side for VPC's.  I want to trunk my Fortinet distribution switches to my Cisco infrastructure so I can leverage other vlans in my Fortinet firewalls.  Any thoughts?

14 REPLIES 14
rwpatterson
Valued Contributor III

Why not use industry standard LACP instead?

Bob - self proclaimed posting junkie!
See my Fortigate related scripts at: http://fortigate.camerabob.com

Bob - self proclaimed posting junkie!See my Fortigate related scripts at: http://fortigate.camerabob.com
hubertzw
Contributor III

bmduncan34 wrote:

 "vpc port channel mis-config due to vpc links in the 2 switches connected to different partners"

 

I think your cabling is wrong. Let's say VPC100 and VPC200 are configured on both switches. But VPC100 on both connects to FG1 and VPC200 to FG2 (on both).

 

On FGT you configure LAG:

 

edit "p1-p2"
set vdom "root"
set vlanforward enable
set type aggregate
set member "port1" "port2"
set snmp-index 15

 

bmduncan34
New Contributor III

Thanks very much.  In my situation I'm terminating on managed 1048E switches; with 601E's hosting  the switch controller.  So I get the cabling and using two different vPCs on the 9K's, but on the FortiSwitch side would I have two mclags, that would correspond to VPC100 and VPC200?  So there would be an "MCLAG to VPC100" and an "MCLAG to VPC200".  Think that would work?

 

Thanks again. 

hubertzw

My fault, my reply was about n9k and Fortigate not Fortiswitch. It makes huge difference. I don't think you can use vpc between them.

bmduncan34
New Contributor III

I plan to get this working this week; been away, but I've been running this setup through my head.  So here's my conclusion; vPC's are what the Nexus 9Ks are using to present a single logical switch across two physical chassis, and mclag is what Fortinet is using to do the same thing.  In both cases the technology (vPC and mclag) result in a single logical switch with a single MAC being presented on either side.  So it's the same as if I were trying to build a port-channel (aggregate) between just one 1048E and one Nexus 9K.  And as far as cabling goes, that shouldn't matter one bit.  Of course it would be nice to build the port-channel in a full mesh, but not necessary.  The port-channel, using LACP with at least one end in Active mode, and the other in either Active or Passive, should just come up.  In my case with just two fibres connecting two different chassis.  Of course I can scale that out as needs be with additional fibres on the same mclag/vPC. 

 

I'm going to tear out my vPC on the Nexus side and build a fresh one tomorrow.  I had been just re-using one that was no longer in production so perhaps there was some corruption there.  When I get this up and running I'll let you know what ended up working.  There must be some other folks out there who've had the same need, anyone want to share their experiences?

bmduncan34

I got this working finally.  I rebuilt the vPC on the Cisco side and the port-channel came up.  So now I've got a trunk between a pair of 1048E's (mclag+icl) and a pair of Cisco Nexus 9K's with vPC.  I'm having a problem getting the trunk to pass layer 2 traffic at the moment but I'll work with support to figure that out. 

Huey
New Contributor III

Trying to do this as well.  Can you share the FortiSwitch MCLAG config?  Heres what I have:

 

 

edit "GCAS-LAG"   set description "GCAS VLAN Uplink"   set mode lacp-active   set mclag enable   set members "port43" "port44" next

This is resulting in two separate LAGs and on one of the 1048E's the LAG is blocking while on the other 1048E it shows forwarding.  There could be a mis-config on the Cisco side but I dont have access.  Looks like 2 separate LAGs.

 

Also, how did you solve the VLAN forwarding?

Layer8 Consulting

http://www.L8C.com

 

Layer8 Consulting http://www.L8C.com
bmduncan34
New Contributor III

Is this MCLAG set as a trunk?  And if it's a trunk is STP turned off?  So this is a four-member MCLAG, with port43 and port44 on each 1048 as members?  Are you using the UI to build this MCLAG?  Sorry for all the questions.  In the UI I would just create a new trunk, then add those four ports (two from each 1048), then ensure you turn off spanning tree on the trunk.  The Cisco side should just be a port-channel configured as a trunk.  See if they're using an allowed vlan statement.  On your trunk build the vlan interfaces you want to see from the Cisco side and create them on the Fortinet side.  Then add those vlans to the trunk on your side. 

 

The biggest thing to be careful of is spanning tree.  You run a risk of getting a loop in your network if you have spanning tree issues, and saw that a couple of times connecting to our Cisco environment. 

bmduncan34

How did you make out?  Let me know as it's definitely working in my environment.

Top Kudoed Authors