Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
New Contributor

Active-Active cluster issues both unit shown as master

Hello, First and foremost, my apologies if I posted in the wrong forum, I couldn' t find the appropriate forum to ask my question. If an administrator would so kindly move the thread to a more appropriate forum I will appreciate it. I bought 2 Fortinet units 240D, we are planning in configure an active-active cluster, they are both the same model, same firmware and I' m configuring from scratch. I follow the instructions in the High Availability for FortiOS 5.0 guide, specifically on page 28. For unit 1 config system ha set mode a-a set group-name fg-ha-1 set password HApass set hbdev port1 50 set priority 255 end For unit 2 config system ha set mode a-a set group-name fg-ha-1 set password HApass set hbdev port1 50 set priority 1 end Then I shutdown both unit and power-on Unit 1, I let the unit to power on completely, then do the same for Unit 2, the problem is that after this, through the gui, both units are shown as been part of the cluster, at the same time, both units are shown to be as master. I have also followed the instructions on the fortigate-cookbook 50-vol1, on page 87 to create a a-p cluster, returning the configuration of both units to factory default before doing the a-p configuration, and the same behaviour, both unit shown as master. I' m not expert by any means in fortinet / fortigate / fortios, but I do believe that in a cluster, even an active-active one, one member must be the master and the others must be slave, the master member coordinating the transactions in the cluster. Am I doing something wrong in my configuration, am I missing something or perhaps I' m not fully understanding the fortigate and the HA implementation? Any help is appreciated. Thanks and have a good day.
New Contributor

I solved the issue. I assumed since both fortinet where brand new they would both come with the same firmware installed, so I didn' t check the firmware version. Once I realized they might not have the same firmware I checked the unit and inded, the firmwares where different. I upgraded both units to the latest firmware and presto, the HA worked like a charm. Thanks and have a good day

Thank you for following up with the solution.

Bob - self proclaimed posting junkie!
See my Fortigate related scripts at:

New Contributor III

Thanks for the update.. First & Foremost requirement is to have the same Firmware & Patch level. So are you finally working with A-A or A-P Cluster ?

Ahead of the Threat. FCNSA v5 / FCNSP v5

Fortigate 1000C / 1000D / 1500D