Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
ipranger
Contributor

[solved] Forticlient SSLVPN Linux don' t set routes automaticly

Hi, We use forticlient-SSLVPN for Linux on all us Desktops (Latest Version). We have some Ubuntus, Gentoos and other systems. I ' ve written an Ebuild for Gentoo to install forticlient easily. This Ebuild, when is ready it goes up to portage. (Same *deb) But there is one dependencies problem in Gentoo. I can install forticlient, and i can use it, but the routes will not automaticli added to the system . With every connection i must set my route to vpn. It' s not a rightproblem because with root it still the same. Here are my dependencies: net-dialup/ppp app-emulation/emul-linux-x86-gtklibs sys-apps/iproute2 Maybe there are some special flags for the Linuxkernel? The strange thing is. I have here an working Gentoo with which the routes are automatically generated. The systems runs since years. So i don' t know what is here and what es not on an fresh installed system. With an Ubuntu it works fine. Thanks for help. Best Regards IPranger

Fortigate 60E v7.x (GA)

Fortigate 60E v7.x (GA)
3 REPLIES 3
ipranger
Contributor

I' ve solved the problem. On newer linuxsystems the net-tools have a new syntax. Useflag in gentoo that must be enabled:
old-output : use old ifconfig output style (useful for when new output breaks scripts)
I must test this things for the new net-tools: http://forums.fedoraforum.org/showpost.php?p=1588849&postcount=5
In the file : sysconfig.linux.sh you will found a line like that : addr=`ifconfig $ifn |grep " inet" |awk ' {print $2 }' | awk -F : ' { print $2}' ` replace it by : addr=`ifconfig $ifn |grep " inet" |awk ' {print $2 }' ` (I just removed the last piped awk)

Fortigate 60E v7.x (GA)

Fortigate 60E v7.x (GA)
ipranger
Contributor

Ok, this is the solution, it works fine!

Fortigate 60E v7.x (GA)

Fortigate 60E v7.x (GA)
mimosinnet
New Contributor

I wonder if this gentoo ebuild is still available. Thanks.

mimosinnet
mimosinnet
Top Kudoed Authors