Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
FredPaul
New Contributor III

Very bad audio quality on FortiAP U421EV

Hi,

 

I have two installations with a Fortigate (two different models) and a single FortiAP U421EV pr installation. When using WIFI calling or audio via Teams the sound quality is horrible. I tried switching to an AP from a different vendor, and the quality was absolutely fine. I also tried turning off WIFI on my phone in the middle of a call, and audio quality is immediately restored to good quality. When running via the U421EV it's barely possible to hear what the other end is saying.

 

I used to have the U421EVs installed at a customer connected to a FortiWLC, and the customer had the exact same issue. It was so bad they ended up replacing all APs with a different vendor.


I've tried turning off SIP-ALG and SIP session helper. I don't have any DDoS policy applied, and the policy for the traffic doesn't have any UTM profiles on it or anything. I tried upgrading so both the Fortigates and the FortiAPs are on the latest version. As I said, the audio is fine on an AP from a different vendor, so the issue must be with the AP model.

Does anyone have any idea what's going on? Has anyone experienced this before?

PS: I do realize this is an old AP model :)

-Fredrik
-Fredrik
3 REPLIES 3
gfleming
Staff
Staff

It's likely a configuration of the AP Profile and SSID. Can you please post the AP Profile and SSID configurations?

Cheers,
Graham
Markus_M
Staff
Staff

Hi Fred,

 

be aware that wireless networks are very different to wired ones. The medium is not visible copper but air. And the medium is shared with other APs and with other things like concrete walls and metal objects. Distance, placing and usage of wireless on this channel can have easily a serious effect on connection quality. The hotspot is in another room with concrete walls - may not work. 25 phones in the same room all connected - may not work. The medium will transport only one at a time. The more SSIDs and the more clients there are the worse for everyone.

 

Get a wifi analyzer on the phone and see the channel usage of the AP and other APs (the AP is a good one, despite old). Less SSIDs are better. 3 or more on one channel is not good, switch to another channel. Test with another frequency like 2.4GHz<>5GHz. There are professional site surveys which exactly tell you where to place the APs based on the building environment.

 

hope this helps.

 

Best regards,

 

Markus

tobypittman
New Contributor

To fix Speaker audio follow the given points.

  1. Check for wireless interference and adjust channels.
  2. Review QoS settings on FortiGate for voice prioritization.
  3. Verify FortiAP configuration, including radio settings.
  4. Implement traffic shaping on FortiGate for voice traffic.
  5. Ensure both FortiGate and FortiAP have latest firmware updates.
  6. Enable debug logs and packet capture for analysis.
  7. Experiment with alternative configurations.
  8. Contact Fortinet and FortiAP support for assistance.