Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
New Contributor

Unable to create Aggregate Interface

Hey everyone,


I'm trying to create a basic etherchannel/aggregate interface, but in the GUI, I get "system error", nothing else. So I tried in the CLI, to determine if it provides me a more descriptive error message and it does:



It is necessary to flush the firewall sessions in order to rebalance the traffic.could not add port4 aggregate aggregate. Object set operator error, 5, discard the setting.Command fail. Return code 5.

I tried clearing the session table with "diagnose sys session clear", no difference.

I checked the port settings, identical . Assigned to correct vdom. Tried disabling/enabling port4 etc. I created two other aggregates with separate ports, no issues, something odd with this port4. It's got 0 references to anything (same for port3).


I searched the forum, saw a thread, someone fixed it with a reboot, which I want to avoid, in case it's a different issue. Just curious has anyone seen this before and have a solution, other than reload?



Esteemed Contributor III

It would help to see the exact error but i would start by double checking refcnt




   diag sys cmdb refcnt show port3

   diag sys cmdb refcnt show wan4


and you could do the follow 


  "show full-configuration | grep -f port3"


See if any one of the above shed some light.


Next, i would double print table out to a file and look any any limits for that model and fortios version



e.g ( linux macos ssh ) 



ssh admin@x.x.x.x "print tablesize" > maxvalues 

cat  maxvalues | egrep -i "(aggre|bond|interface)"



Ken Felix





Esteemed Contributor III

a bit nit-picking here, what Ken meant is

"diag sys cmdb refcnt show port4"


"show full-configuration | grep -f port4"


AFAIK there is no 3-link-limit to an LACP trunk, minimum is 8 (out of memory).


My best guess is that the ref counter is 'stuck' and will be released after a reboot. You've got to find a windows for this I'm afraid.


"Kernel panic: Aiee, killing interrupt handler!"

Thanks for the responses. Reboot fixed it.