Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
New Contributor

Fortigate 60d boot device failing

Hello community,

I'm a student and I just bought a fortigate 60d firewall from a reseller for a cheap price (in comparison to original price but not cheap for me) and I connect to it using mini usb management port and putty. The thing is it doesn't boot the firmware it just says:

System halted, check boot device or OS image.

I think this is the reason behind the cheap price, and I'm thinking the problem is in the flash memory failing because I trued a lot of firmwares oldest and new ones and same problem.

I managed to find an internet article about the same problem and the workaround is some kind of jumper that you put to the circuit board to skip the flash to USB drive containing the OS but it was for a different fortigate and I know nothing about electric circuits so I can't try that with no guidance or is it even possible on the fortigate 60d.

Please help me I'm in a dead end.



You can try to perform a Clean install procedure:

you'll need:

- Serial console cable.

- Putty.

- Firmware for FGT60D

- TFTP server.


Jonathan De La Fuente | LATAM TAC Engineer

Hi, I already tried that with different versions of its firmware but in the last step where it asks for permission to reboot (yes/no) when I type yes it just stucks there, in addition to stucking when I try to format flash so I think the problem in flash memory


Hi @Ayoubm,


Have you tried to follow this article?


6.0.18 is the latest you can go with 60D. You can try this version. 



New Contributor

Here you go my friend, the problem is after uploading the firmware and pressing D to set as Default and confirming with Y it just stucks there and after rebooting by removing power it says system halted.


Thanks for replying btw I really appreciate your time!

Top Kudoed Authors