Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
judywatson
New Contributor

FortiClient 7.0 Crashes on Red Hat Enterprise Linux 8.4

Hello everyone,

I'm encountering an issue with FortiClient 7.0 on Red Hat Enterprise Linux 8.4. After following the installation guide, which involved adding the repository and executing 'dnf install,' the application consistently crashes upon launch.

My Red Hat [ https://www.lenovo.com/de/de/servers-storage/solutions/redhat/ ]system is configured to comply with CC GPOSPP (Common Criteria General Purpose Protection Profile), including various built-in security configurations. I suspect that the crashes might be linked to the active security policies. Is it possible that FortiClient 7.0 is not fully compatible with Red Hat Enterprise Linux 8.4?

Below are the system details for reference:

Kernel version:
Linux rhel8 4.18.0-193.el8.x86_64 #1 SMP Fri Mar 5 15:26:14 EST 2021 x86_64 x86_64 x86_64 GNU/Linux

Red Hat release:
Red Hat Enterprise Linux release 8.4 (Ootpa)

Upon checking the system logs, a segmentation fault (SIGSEGV) error was observed during the FortiClient crash.

Is there anyone available who can provide guidance or assistance in troubleshooting this issue with FortiClient 7.0 on Red Hat Enterprise Linux 8.4?

Thank you.

1 REPLY 1
AEK
SuperUser
SuperUser

Hello Judy

Make sure you use the right version. According to admin guide, FortiClient 7.0.9 and newer is supported on Red Hat 9 or newer, while FortiClient 7.0.8 and lower is supported on Red Hat 7.4 or newer.

https://docs.fortinet.com/document/forticlient/7.0.9/administration-guide/646779

AEK
AEK
Announcements

Select Forum Responses to become Knowledge Articles!

Select the “Nominate to Knowledge Base” button to recommend a forum post to become a knowledge article.

Labels
Top Kudoed Authors