Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
New Contributor

Failed to add FG VM to FMG VM "probe failed"

Dear All,

I am trying to test FMG and FG in lab environment, both VMs are registered in Forti cloud (latest versions)

Tried all the possible steps to troubleshoot, changed the enc-algorithm, added the device from FG-VM security fabric manually with IP, FMG Access enabled on the corresponding interface, both devices are reachable via icmp


# Tried the below debug as stated in community forum

diagnose debug reset
diagnose debug disable
diagnose debug application depmanager 0
diagnose debug application depmanager 255
diagnose debug enable


FMG-VM64-KVM # Request [dvm/cmd:dvm/cmd/discover/device ...:26295:2]:
{ "client": "dvm\/cmd:dvm\/cmd\/discover\/device ...:26295", "id": 2, "method": "exec", "params": [{ "data": { "host": "", "passwd": "******", "usr": "admin"}, "target start": 1, "url": "probe\/device"}], "root": "deployment", "session": -1}
Chkperm Response [dvm/cmd:dvm/cmd/discover/device ...:26295:2]:
{ "id": 2, "result": [{ "status": { "code": 0, "message": "OK"}, "url": "probe\/device"}], "session": -1}
start_dmsvc_probe_device,788: dev_oid=0, host=, flags=0x0
__enter_state,440: dev_oid=0, start check_reachable
Start probe_dev.check_reachable ...
__on_state,446: dev_oid=0, check_reachable, done, events=16 r=0
__enter_state,440: dev_oid=0, start start_probe_session
Request [dmserver:1412:16]:
{ "client": "dmserver:1412", "id": 16, "method": "exec", "params": [{ "data": { "detect_only": 0, "force_probe": 0, "ip": "", "passwd": "******", "usr": "admin"}, "url": "start\/probe\/session"}], "root": "fgfm"}
Start probe_dev.start_probe_session ...
Response [unknown]:
{ "id": 16, "result": [{ "status": { "code": 1, "message": "internal error"}, "url": "start\/probe\/session"}]}
__on_state,446: dev_oid=0, start_probe_session, done, events=8 r=0
__fgfm_cb,619: error: probe_status=1, proto=1
__p_o_cleanup,548: cleanup...
__p_finish,539: status=-15, has_devinfo=0
Response [dvm/cmd:dvm/cmd/discover/device ...:26295:2]:
{ "id": 2, "result": [{ "status": { "code": -1, "message": "runtime error 0: invalid value"}, "url": "probe\/device"}]}
__o_cleanup,119: fgfm probe cleanup...



Kindly assist please. thanks


Hi @chandima5320 ,


Please review this article:

Please find the articles about installing of FortiManager VM:
Note: The FortiManager can support only ADOMs two versions below

jokey-fmg-esx27 (central-management) # get
mode : normal
type : fortimanager
schedule-config-restore: enable
schedule-script-restore: enable
allow-push-configuration: enable
allow-push-firmware : enable
allow-remote-firmware-upgrade: enable
allow-monitor : enable
serial-number : "FMGVMxxxx"
fmg : ""
fmg-source-ip :
fmg-source-ip6 : ::
local-cert :
ca-cert :
vdom : root
fmg-update-port : 8890
include-default-servers: enable
enc-algorithm : high
interface-select-method: auto <<<< Try to change to the proper interface


Select Forum Responses to become Knowledge Articles!

Select the “Nominate to Knowledge Base” button to recommend a forum post to become a knowledge article.

Top Kudoed Authors