Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
New Contributor

sip-helper disable - problems with RTP ports

I'm still trying to figure out why my FG100E keeps moving around my RTCP/RTP ports, when I don't want it to do that.


One question, I've typed these commands into the command line:


config system settings set default-voip-alg-mode kernel-helper-based set sip-helper disable set sip-nat-trace disable end


But when I look at the config text file, the "set sip-helper disable" part is not in the config. 

Shouldn't it appear there if I have really turned off the Helper? 


I've made all sorts of other changes to disable rtp in the voip profile, etc., but my RTP ports keep changing on my traffic. So it makes me think the SIP Helper is still doing something. 

Esteemed Contributor III

That's because "disable" is the default value. If you do "get | grep sip" under config sys setting, you would see it's disabled. But that doesn't seem to completely disable the SIP session helper. You need to remove the actual SIP helper under "config sys session-helper". I think it's "edit 12" or "13". You should check before removing it. This require a system reboot to take effect.

By the way "set sip-helper enable/disable" was even removed from 6.2. I think that's because removal of the SIP session-helper would do and still be required.



Thanks for the reply, makes sense. I'm on 6.0.10

Top Kudoed Authors