Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
New Contributor III

SSLVPN and RDP disconnects

Hey folks,


Ever since upgrading my 200D to 6.0.5 (now 6.0.9) when using the FC to connect to the SSL VPN, I have constant disconnects with Outlook and RDP sessions. Pings never fail or timeout, but I get disconnected from my RDP sessions every minute or so, making it completely unusable.

I have a ticket open with support, but honestly, they seem to be dragging their feet. Anyone else seen this behavior and figured out a solution? I have 150 users about to be forced to WFH and this is completely unacceptable. The only work-around I've found is using an IPSEC connection, but that's not realistic. 

1 Solution
New Contributor III

I updated the fw on Saturday morning. I've had zero issues in the last 30 hours. More importantly, no disconnects of authenticated traffic - https, mapi, rdp, etc. It solved our issues, but I hate running an interim build on what is essentially the brain stem of my network.

View solution in original post


@Oskarprez, I recommend you open a TT at TAC. As you saw in the thread the RDP issue seemed to have been fixed by 6.0.10 for most of situations, including ours. There might be some exceptions for a new hardware like 60F. We wouldn't know until opening a TT.


Thank you Toshi, I will do that and update the info. regards

New Contributor

We use 100E with 6.0.11 and FortiClient and still experience RDP disconnections. So the issue is still around.

New Contributor

But my problem solved after removed route from server end.

New Contributor II

Hi ,

Can u kindly explain the kindly of connectivity you have arrange for the WFH people to connect to your network.


SSLVPN--->RDP(only) or SSLVPN-->into company network


We have fg 300 in our location .. but  we have designed SSLVPN user to connect only to RDP PC ..

We also divided and limited number of user per VPN user GROUP as 10.


total number of RDP pc or 85 and total number of VPN users are close to 100.


Our fg 300 cpu uses 4% and spike to 30%, if any configuration change is made at that rest ofthe time iit is around 4%.

where the memory usage is 65% to 69% at constant.


you may face VPN disconnection  at the time of configuring vpn user and placing those config to SSL VPN setting -->Authentication/Portal Mapping area.

BUT rest of the time the VPN will work fine.

WHAT kindly of VPN client you have installed at you end device.

we have installed forticlient (complete solution supporting av,vpn and application filter).






New Contributor




I had the same issue with a Forti VM02 running FortiOS 6.2.3 code.

The problem was a firmware bug, I am not 100% sure, but I think this problem can also happen on lower firmware versions like 6.0.5/6.0.9.


I opend a ticket, and after a few log files I sent to the support, they gave me a special firmware that fixed the bug.


but i think this is the faster way:


Take a look at the release note of 6.0.10, it seems they fixed it with this:


"RDP sessions are terminated (disconnect) unexpectedly."




New Contributor

We are using FG-60E with v6.0.10 build0365 (GA) still facing auto RDP reconnections issues?

New Contributor

We have FG100E with 

v6.0.11 build0387 (GA)

SSL VPN connections to Windows servers (2008,2012 or 2016) have disconnections. Opened a TT but no help at all. I had to use the VPN portal instead untill there will be a real fix.


BTW this happened after I move from 6.0.5


Select Forum Responses to become Knowledge Articles!

Select the “Nominate to Knowledge Base” button to recommend a forum post to become a knowledge article.

Top Kudoed Authors