Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
New Contributor

Port forward to RDP

Hello all,


Basicly I installed Forticlient-VM and Windows Server 2022 on Hyper-V.

Everything seems to work Ok except port forward.

This is how I set up th VIPSchermafbeelding 2023-09-27 215844.png

Interface = any (also tried WAN)
Type = Static NAT
External IP address/range = WAN (Also tried
Map to IPv4 address/range = Server ip - LAN network
Port Forwarding = ON
Protocol = TCP
Port Mapping Type = One to one
External service port = 3389
Map to IPv4 port = 3389

I have also created firewall policy

Schermafbeelding 2023-09-27 220844.png

Can any help me with any kind of a solut




Hello, have you verified the procedure described in this article?

Fortigate, VoIP

I will try this later today.

I'll let you know.


Contributor II

Dear Nuur,


in your policy you have set both the incoming and outgoint Interface to "Wan (Port1)"

usually you have to set the lan facing interface on the outgoing site

maybe this could be the problem here.

sudo apt-get-rekt

sudo apt-get-rekt
New Contributor

Hi Hosemacht,


I have tried that. Unfortunately not the solution

Schermafbeelding 2023-09-28 100300.png


Thanks though



Hi @Nuur ,


If you are sure about incoming interface port1 and outgoing interface port2 , then configuration look fine.

You might have to check debug logs to understand the exact issue. 

get router info routing detail 
get router info routing detail
get router info routing detail <source>

show sys interface port1
show sys interface port2

diag debug reset
diag debug disable
diag debug flow filter clear
diag debug flow filter addr x.x.x.x <--- source ip address
diag debug flow show iprope enable
diag debug flow show function-name enable
diag debug console timestamp enable
diag debug flow trace start 9999
diag debug enable

generate the traffic from source ip address x.x.x.x and once get the error in the connection , then stop the debug using below commands.
diag deb disable
diag deb reset

Hope you will be able to see logs and it will tell you the exact issue.


Mayur Padma

Hello @Nuur ,

From what IP does a user tries to RDP into the internal PC, is the IP used from the external user is public IP or it's the IP  , if its public IP please use in external IP,

Also please disable the NAT in the firewall policy,

Let us know if that does not helps.

New Contributor

Hi pmeet,


it's not working with as the external ip 


Schermafbeelding 2023-09-28 195940.png


Hi @Nuur,

Is your interface of port 1? Are you connecting from inside or outside of your network and from where you connect, is it routable to Also tried to remove the VIP from policy and change interface binding to port1.


New Contributor

I am connecting from outside to

I removed the NAT but stil not working 


is it routable to

I configured static routes if you mean that

Schermafbeelding 2023-09-28 200843.png


Select Forum Responses to become Knowledge Articles!

Select the “Nominate to Knowledge Base” button to recommend a forum post to become a knowledge article.

Top Kudoed Authors