Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
New Contributor

Password Reset on a 20C

Hello,  I just bought a used 20C.  The admin password is not the default.  The 20C has a UBS cable for the console.  I installed FortiExplorer but I'm not able to use the ID maintainer with the bcpb+serialnumber password.  I understand it's on a timer where you have to do it within so many seconds. 


When I power on the 20C, FortiExplorer shows me a console screen.  As the unit boots and gives me some info.  But then the console disappears and the I can't get back in to the console until the unit finishes booting.  By the time it does, maintainer won't work. 


I tried using putty, but the 20C does not show up as a COM port in the Windows Device manager.  So I'm at a loss.  What am I doing wrong?  I can't find any 20C specific documentation that answers this.






FortiExplorer and Console are two different ways.

What you need is a console cable that you can find it in the box.Then connect it to Console Port of FortiGate.If your client does not have serial port you can connect it to a Serial to USB convector.

So you should find the port in device manager and now you can use putty .


Honored Contributor

Hi Chris.  Supposedly pressing the reset pinhole (next to power) should restore the fgt to factory defaults.

NSE4/FMG-VM64/FortiAnalyzer-VM/6.0 (FWF30E/FW92D/FGT200D/FGT101E/FGT81E)/ FAP220B/221C

NSE4/FMG-VM64/FortiAnalyzer-VM/6.0 (FWF30E/FW92D/FGT200D/FGT101E/FGT81E)/ FAP220B/221C
New Contributor

Thanks for the suggestions. I had tried the reset but couldn't get it to go.  I just tried it again and it reset this time!  So my problem is solved.


The 20C seems to be a little different from the larger units.  It has both a type A & B USB plug.  The type B USB is marked Management.  There is no DB9 or RJ45 serial ports.  It has 4 LAN Ethernet ports and 1 WAN Ethernet port.  I got the unit used so I don't know if there might have been some special adapter in the box to emulate a serial console port.


I tried the reset several times last night and never could get it to work.  I tried it today and it worked!  The only thing I did different was I had it plugged in to a USB cable attached to a PC running FortiExplorer.  I don't know why or if it cared, but that seemed to be the only difference between now and last night.


Thanks again for your suggestions!



New Contributor III

Strange to hear that there is no Serial console Port. Type A USB connector is to load Firmware via USB which device can be configured to do automatically on reboot

Ahead of the Threat. FCNSA v5 / FCNSP v5

Fortigate 1000C / 1000D / 1500D


Ahead of the Threat. FCNSA v5 / FCNSP v5 Fortigate 1000C / 1000D / 1500D
Top Kudoed Authors