Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
New Contributor

IPsec VPN issues with Pre-shared key

Hello everyone,


I am in my first year of an IT degree, I am very new to all this. For our programming course, we use the university's coding environment, to use it we have to connect to the university VPN.


The university uses Forticlient, we have to follow an instruction document explaining how to download Forticlient and change the configuration settings.


This has always worked for me, I was able to access the uni's VPN just fine for months, now suddenly there have been some issues. It won't let me in, so I tried all kinds of things, I tried changing my uni password (because we use our uni credentials to log in to the VPN), which didn't work. I tried uninstalling and re-installing forticlient, which didn't work. I tried re-entering all the configuration settings over and over, still I had the same issue.


Then I noticed that when I save and exit the configuration settings, and then re-open them, the pre-shared key is different, it's longer, forticlient seems to be automatically changing the pre-shared key upon saving.

I don't understand why it's doing this and I have absolutely no idea how to fix it. Does anyone know how to solve this issue? Any help would be greatly appreciated.


Thank you :)

Contributor II

Pre-Shared key is not changed, instead after you input it shows hidden and longer only. 


In this case the only method for you is to contact your Network / IT Firewall Team. Because all the configurations are based on Fortigate Firewall configuration. Nothing can be done From forticlient side. Forticlient can not do anything to sort this. COntact your IT team to get the right details or right reason why your facing this. 

Rosa Technocrat -- Also on YouTube---Please do Subscribe
Rosa Technocrat -- Also on YouTube---Please do Subscribe
New Contributor III

I don't think the issue is with the pre-shared key. If you save and re-open the connection the key is obscured (replaced with 20 dots) so that an unauthorized user cannot infer the key length, but the key you entered is still used unless you change it.

If possible, test with another device, otherwise you probably need to seek support from your university.

Top Kudoed Authors