Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
kaMo
New Contributor

Mail queue is getting bigger ( Outgoing slow )

Hello Guys ,

 

Our Mail queue is getting bigger ( Outgoing slow ) . I get this as reason.

"Message deliver is delayed because maximum recpient(s) per period is reached" can somebody help me please ?
Thank you ,
 
 
9 REPLIES 9
Jakob-AHHG
Contributor II

Seems like the remote end has a cap on how many emails pr. hour you can send, and you are above that limit.

Not sure if you can make an Outgoing Recipient Profile that sets a limit to handle it?

Jakob Peterhänsel,
IT System Admin,
Arp-Hansen Hotrel Group A/S, Copenhagen, DK
Jakob Peterhänsel,IT System Admin,Arp-Hansen Hotrel Group A/S, Copenhagen, DK
AEK
Honored Contributor II

Hello

Can you share a screenshot of your outgoing session profile.

In the first section there is a field like "maximum number of recipients per client per X minutes". That should be the issue.

AEK
AEK
kaMo
New Contributor

 
 

Thank you for your reply.

This is the ountbound profile.

  1. 2024_01_23_15_55_10_My_FortiMail_Cloud_Mozilla_Firefox.png
 

 

AEK
Honored Contributor II

Try increase max recipients per client per 30m. You can set it to 2000.

AEK
AEK
kaMo
New Contributor

Hello ,

 

I did the changes ( to 2000) but still are mails getting mail qeued.
This is what i find in the cross search result under message: delay=00:20:03(tries=3), xdelay=00:00:00, mailer=esmtp, pri=315695, acl_delivery_id=1, relay=xxx.0e...ection.outlook.com [52.101.68.16], dsn=4.2.0, stat=Deferred(Reason:Message deliver is delayed because maximum recpient(s) per period is reached)

AEK
Honored Contributor II

Try this.

Sender address rate control

For users under this domain, you can rate control how much each user can send email.

  1. Go to Domain & User > Domain > Domain.
  2. Either click New to create a protected domain or double-click a domain to modify it.
  3. Click to expand Advanced Setting.
  4. Click to expand Sender Address Rate Control.
  5. For email users under this domain, you can configure the following rate control settings per user:
  • Maximum number of messages per half hour. The default value is 30.
  • Maximum number of recipients per half hour. The default value is 60.
  • Maximum data size per half hour (MB). The default value is 100 MB.
  • Maximum number of spam messages per half hour. The default value is 5.
  • Send email notification upon rate control violations and select a notification profile (see Configuring notification profiles).

 

Ref:  https://docs.fortinet.com/document/fortimail/7.4.1/administration-guide/40774/configuring-protected-...

AEK
AEK
kaMo
New Contributor

 

This option is even disabled.

I can't figure it out where the exact issue is

2024_01_23_15_55_10_My_FortiMail_Cloud_Mozilla_Firefox.png

AEK
Honored Contributor II

Hi Kamo

If I understand well the log, the mail relay "xxx.0e...ection.outlook.com" has returned the message "Deferred(Reason:Message deliver is delayed because maximum recpient(s) per period is reached)".

So it leads to some questions:

  • Is your FortiMail forwarding your outgoing mails to that mail relay?
  • Are all your outgoing mails affected or just some?
AEK
AEK
AEK
Honored Contributor II

Hi Kami

Just noticed that there is a bug that was fixed in the latest versions 7.0.7 & 7.2.4.

925041  Outgoing email stuck in the queue.

It may be your case.

AEK
AEK
Labels
Top Kudoed Authors