Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
New Contributor

Help with error "...may be caused by a mismatch in the TLS version. ..."

Hello folks,


I am trying to connect to my work VPN server using FortiClient v. on Windows 10 x64, but every time I enter my username and password, it says "Warning - Failed to establish the VPN connection. This may be caused by a mismatch in the TLS version. Please check the TLS version settings in the Advanced of the Internet Options. (-5029)".


I have checked the Advanced panel under Internet Options, which has checkboxes for "Use SSL 3.0", "Use TLS 1.0", "Use TLS 1.1", and "Use TLS 1.2". When I first checked, the boxes for SSL 3.0 and TLS 1.0 were unchecked, and TLS 1.1 and TLS 1.2 were checked. I tried checking TLS 1.0 in addition to 1.1 and 1.2 and restarting my computer, but it still fails. I have tried several other combinations (like unchecking 1.1 and 1.2, so only 1.0 was checked, or checking only 1.1 or only 1.2, etc.) to no avail. I have also tried uninstalling and re-installing the FortiClient app with no success.


This started after my computer told me it needed to restart to finish installing some Windows updates, specifically KB4093112 (2018-04 Cumulative Update for Windows 10 Version 1709 for x64-based Systems). I had also just installed Visual Studio Build Tools 2017, in case that may be pertinent.


I am also emailing my workplace's computing services department in case they have seen this issue before, but any assistance would be much appreciated.


Best Regards,

Matt S.

New Contributor III

I'm seeing the same type of issue, but just trying to get to secure websites through a browser (Edge, IE11, and FF all do it).

Esteemed Contributor III

Okay are you  using the forticlient or web-portal? Are you going thru a proxy ? Have you ran diag debug application sslvpnd -1 ?


What do you have enabled on the  SSLVPN  as far TLS versions ?

 try ssl-tools

( you will need a FQDN )







PCNSE NSE StrongSwan

Hello, guys


Sorry for kind of necroing the thread.

Have you found any solution to this problem? One of my external vendors is having the same symptoms as the OP.


Have u try to check at security levels at internet option site? i'm facing this problem before which is related with the security level at internet option. Once i reset it, the problem solved.

New Contributor III




Its seems to windows patch issue . 


Can you please refer the below link. 


Sudarsan Babu P

Regards, Sudarsan Babu P

Select Forum Responses to become Knowledge Articles!

Select the “Nominate to Knowledge Base” button to recommend a forum post to become a knowledge article.

Top Kudoed Authors