Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
swmar
New Contributor

Fortiswitch LLDP to get vlan for IP Phones

Dear all,

 

Would you please advise about an issue that we have when we enabled lldp on fortiswitches.

We have applied below configuration to let the IP Phone take the vlan ID from lldp, but unfortunately it is not taking.

would you please advise what is missing please, and the IP phone is Unify cp200 (x Siemens brand)

Anything to be modified from the IP phone side.

 

your fast response is highly appreciated

 

 

 

config switch-controller lldp-profile edit "voice" set med-tlvs inventory-management network-policy config med-network-policy edit "voice" set status enable set vlan 110 next edit "voice-signaling" set status enable set vlan 110 next On my fortiswitch: config switch physical-port edit "port1" set lldp-profile "voice" set speed auto next end

 

and lldp is enabled globally from lldp setting page.

 

Thank you,

2 REPLIES 2
swmar
New Contributor

Any update please!!?
thuynh_FTNT

Hi swmar, sorry for the delay.

 

With your case, look like this is an issue specific to Unify phone? Does other device type have the issue?

 

For Unify phone, you need to make sure:

        1) Phone has latest firmware         2) Some phone doesn't handle all forms of standard LLDP-MED frames          Also you may need to allow the VLAN on the FSW port? config switch physical-port    edit "port1"       set allowed-vlans 110    next end
Top Kudoed Authors