Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
Olli_hert
New Contributor

Fortimanager XML API: Problem adding Global Header/Footer Policies to policy package

Hey guys,

I hope someone can help me, I have a problem adding Global Header/Footer Policies to a policy package in the Global Adom  (I tried version 5.2/5.4) via the new Fortimanager API.

 

This is my soap request:

 

<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:r20="http://r200806.ws.fmg.fortinet.com/">
<soapenv:Header/>
<soapenv:Body>
<r20:addPmConfig54AdomObjGlobalHeaderPolicy>
<path>
<adom></adom>
</path>
<!--1 or more repetitions:-->
<data>
<policyid>0</policyid>
<srcintf>any</srcintf>
<dstintf>any</dstintf>
<srcaddr>gall</srcaddr>
<dstaddr>gall</dstaddr>
<action>accept</action>
<status>enable</status>
<schedule>galways</schedule>
<service>gALL</service>
...
</data>
<session>ZjD0QE2dPWEMo49/ZoPZ7LRUWJVuInHzYrNJw6HwUW/cuk7wAz9eOMiz1HEW6esraTOUhfog1lMBuFwgcErrXw==</session>
</r20:addPmConfig54AdomObjGlobalHeaderPolicy>
</soapenv:Body>
</soapenv:Envelope>

 

This request returns OK and creates a new header policy but within no policy package. 

 

[size="3"]I have tried adding

<pkg>default</pkg>
 to path (it works for adding normal policies to an Adom), but it seems this is ignored within this command.[/size]

 

I have tried serveral endpoints for the request like https://<ip>:8080/w...t/global/header/policy

 

Is there a way to specify and package for this request?

In the path field, besides <adom> there are only two options <policy> and <option>.

Do I miss something here? 

 

Thanks for your help

Greetings Olli

 

0 REPLIES 0
Labels
Top Kudoed Authors