Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
Ranithd
New Contributor

Fortigate SSL VPN disconnects between 2-5 minutes suddenly

Dear all, 

Im using fortigate 60E with 5.6 firmware. All users can work only for few minutes & the VPN suddenly gets disconnected. No error comes in. I have installed forticlient 5.6 aas well, but it also give same results

1 Solution
Agent_1994

Sorry for the delay, i was *way* busy 

I had a similar problem with SD-WAN where i work: replies from the ssl vpn were load balanced among our links, i observed traffic going out to wan2 with wan1's IP.

 

It was solved with this:

 

config vpn ssl settings

set route-source-interface enable

end

View solution in original post

17 REPLIES 17
Ashik_Sheik

HI,

 

Normally if you have More than one Wan link ..Below command will help you to solve disconnection issue .

 

set route-source-interface .

 

Just check if you have already run this command .

 

Regds,

 

Ashik

Ashu 

 

Ashu
Juma

Yes I did. Does not work 

 

Also this command below 

 

set source-interface "ISP"  where ISP is the desired link.

Ashik_Sheik

Hi,

 

Try this 

 

Tunnel-mode connection shuts down after a few seconds

This issue can occur when there are multiple interfaces connected to the Internet (for example, SD-WAN). This can cause the session to become “dirty.” To fix this, you must allow multiple interfaces to connect without issue.

If you are using a FortiOS 6.0.1 or later, use the following CLI command:

config system interface
edit <name>
set preserve-session-route enable
next
end

If you are using a FortiOS 6.0.0 or earlier, use the following CLI command:

config vpn ssl settings
set route-source-interface enable
end

 Regds,

Ashik

Ashu 

 

Ashu
jamesd

Ashik, I'm facing the same problem and trying to execute the CLI commands you posted. (V6.0.2)

 

I have 3 WAN connections, the SSL VPN is listening on WAN 1 named "TRUE" these are interfaces under the SD-WAN interface.

 

config system interface
edit <name> // I've tried edit "sdwan", edit "sd-wan", edit "true" & edit "root"
set preserve-session-route enable
next // I get the error after this
end

 

I receive the error:

Attribute 'vdom' MUST be set.
Command fail. Return code 1

 

I assume I'm not entering the correct <name> but I'm not sure what it should be.

 

Can you shed some light on this for me please? 

Ashik_Sheik

Hi

 

Any VDOM is configured in your firewall .In that case you should run this command on respective vdom.

 

Config Vdom 

 edit <vdom name>

  Then try those commands .

Ashu 

 

Ashu
jamesd

Thanks Ashu,

 

That has fixed the issue.

 

 

 

Holy

Hello Guys,

 

faced the same issue first on 5.6.6 and could fix it with 

config vpn ssl settings set route-source-interface enable end 2 Days ago we upgraded to 6.0.3 and had the issue straight away.

 

i applied this

 

config system interface edit <name> set preserve-session-route enable next end But it didnt realy fixed the issue.

 

now we have Random Disconnects i a range sometimes 3 - 6 Minutes, sometimes 10 -15 and sometimes even after 20 Minutes.

 

All users that are currently connected will be disconnected at once.

 

Dont know what to do as we rely on a stable connection for SSL VPN TUnnels.

 

Any Ideas?

 

Thank you

 

 

 

NSE 8 

NSE 1 - 7

 

NSE 8 NSE 1 - 7
mhnd68

Thanks for the help

now it is linked without any disconnection

Top Kudoed Authors