Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
New Contributor

FortiClient on Windows 11 IPsec

Hi there,

I'm having this issue when I try to connect IPsec VPN with FortiClient on Windows 11 it just does not work, I've tried reinstalling many times the drivers of NIC, software, etc and nothing seems to work. One thing I notice is that when I click the button to connect my connection just drop from LAN  but there is no error message, it just stays on "Status: Connecting" forever, it is only when I cancel when my connection comes back.


I read that I could try FortiClient version 6.4.7 but I cant 't find the installer nowhere, also I already tried all suggestions related in this forum with no success.


It is worth mentioning that I dont own any licence or product by Fortinet, this connection I am trying to make was provied from my local cloud provider to connect via RDP to my server and they only say that I should by using Windows 10 to perform the connection.


Any ideas? Can someone share FortiClient 6.4.7 installer with me to test?


Thanks in advance.

Thanks in advance.


Hey aquilesboy,

there was another forum thread for this topic recently, not sure if you checked it:


Did you try the Win10 driver version as suggested? (If you're using a RealTek driver)

Aside from that, you might be able to get an older FortiClient version via a ticket with Fortinet Technical Support (if you, or your company, can open one), but I'm not sure if we can provide that via Forums.

+++ Divide by Cucumber Error. Please Reinstall Universe and Reboot +++

Hi Debbie_FTNT,

Yes, I was going to try that but unfortunately I have an Intel Killer E2600 wich I'm not really sure it have a Realtek chip and I dont really want to screw up something.


On the other side, I tried opening a ticket or a live chat but it ask me for a serial of any product wich I dont possess, perhaps via email?


I understand the concern about your network adapter. It's always a good idea to be cautious. On a different note, have you thought about trying a unique design for your tip nails? They can be a fun and creative way to express yourself!


It's a good suggestion to seek an older FortiClient version through Fortinet Technical Support. If you have any more questions or need further assistance feel free to ask!


Hey aquilesboy,

support tickets require the serial number of a product that is registered and under support coverage, such as a FortiGate.

For FortiClient specifically, a ticket is only possible via the EMS serial number (the enterprise server managing FortiClients, assigning profiles, etc).

The VPN-only (free) version of FortiClient does not receive official support, and only assistance through the Forums (as in this thread :)

As for FortiClient 6.4.7, I have attached the online installer for FortiClient 6.4.7.


You might want to remove your current FortiClient installation first to avoid any interference with the 6.4.7 installation.

EDIT 02/03: removed the online installer

+++ Divide by Cucumber Error. Please Reinstall Universe and Reboot +++

Hi Debbie_FTNT,

Thanks for sharing the installer, unfortunately it didnt work,  it have the same behavior as with 7.0.2.

I guess I'll have to wait until a fix arrives to Windows 11.


Thanks for your time and help.


Sorry I couldn't help more.

If I ever come across other solutions to the Windows 11 issue aside from driver downgrade, I'll update here.

+++ Divide by Cucumber Error. Please Reinstall Universe and Reboot +++

Hi Debbie, I'm facing an almost identical problem currently. I have two laptops with Intel Killer drivers that behave the exact same way as aquilesboy described. I've also seen the downgrade thread(s), tried their troubleshooting steps and additional troubleshooting of my own - no dice.

Sorry to necro, any updates on this specific Windows 11 issue?

I've been watching the Fortinet downloads page and downloading the latest version of FortiClient every month or so since 7.0.4 - nothing works yet. I'm on 7.0.7 and have tried everything back to 6.4.7

Any help is appreciated, unfortunately I'm in the same boat as aquilesboy - no support since I'm using the VPN Only client.

New Contributor II

Fortinet know the problem.


Fortinet Answer: "...there will be no fix from the forticlient side as this is not a forticlient issue.This issue is with Realtek drivers and a drivers update might fix the issue.To avoid this issue, try not to use the latest Realtek driver, it has the bug, just use the driver that comes with Windows and that should work."


There is a new Driver from Realtek 2023/02/24 version 124.011 , 1125.011 , 1166.011 , 1168.011 and it's not fixed.


I tried to contact Realtek about it... no answer...So good luck to reach Realtek about it!


Windows 10 driver on windows 11 works fine.


Select Forum Responses to become Knowledge Articles!

Select the “Nominate to Knowledge Base” button to recommend a forum post to become a knowledge article.

Top Kudoed Authors