Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
New Contributor

FortiClient macOS Ventura can't connect

I can't seem to connect using the free FortiClient using # macOS Ventura. When I get the popup below and I click "Open Security & Privacy Settings" it takes me to the "Appearance" pane, but when I got to Full Disk Access the FortiClient and fctservctl2 does have access. Has anyone solved this issue?

PopupPopupSystem SettingsSystem Settings


Contributor III

If you go to the Privacy and Security section, down at the bottom, do you have a security request for FortiTray still?  


You can also run the following in terminal:


systemextensionsctl list


and make sure that the com.fortinet.forticlient.macos.vpn.nwextension shows [activated enabled]


Thank you for the advice, but there isn't a request anywhere in System Settings, and it doesn't show up in the extension list using Terminal.


I'm guessing it's because macOS Ventura drastically changed the System Settings/Preferences.


I am running FortiClient 7.0.7 on Ventura, so it should work.  You may want to uninstall and try to download and run the installer again.


I've tried that, but willing to try again.


After you run the uninstaller, check the following to see that it is completely removed prior to installing again:


-Open Applications > Utilities > Terminal

-Mac$ cd /

-Mac$ cd Library/LaunchDaemons

-Mac$ sudo rm -rf com.fortinet.forticlient.*

-Mac$ cd /

-Mac$ cd "Library/Application Support/Fortinet"

-Mac$ sudo rm -R FortiClient

-Reboot Computer


Thanks for the steps, checked all of it and made sure everything was gone, rebooted, reinstalled same issue. My login is a domain account with my employer, so I thought maybe there are some permission issues, I uninstalled again, used a local admin account, reinstalled same issue.


I also get the error below, which I forgot to mention.

Screenshot 2022-11-14 at 11.38.05 AM.png


My only other thought is that the MBP M1 is managed by an MDM and maybe there is something blocking the extension. I manage the MDM, but I don't see anything that could be causing this...



Yes, if you are getting a failed extension issue, I would check on the MDM for sure.  There is a good chance there are restrictions in place on there.

New Contributor

I have the same issue on a Macbook Pro running M1 chip.

It asks "To connect to a VPN with FortiClient, open Security & Privacy Settings and allow system software from FortiTray". Unfortunately, there is no FortiTray app installed after the installer made his job.


i've tried to authorize several other apps found in the Library folder and subfolder, with no more success. Any clue ?

Capture d’écran 2022-11-22 à 08.08.02.png

New Contributor

I am having a similar lack of joy with a 2018 MacBook Pro running Ventura 13.0.1 plus the  Forticlient 7.0.7. Forticlient connects, but then Microsoft Remote Desktop 10.7.10(2028) cannot complete the connection. There are no other full disk access requests to switch on; fmon2 is not in the library. I've uninstalled Forticlient, manually combed through the / and ~ libraries and removed any other Fortinet and Forticlient traces, rebooted, and redownloaded and reinstalled Forticlient 7.0.7, no success. I found an old Forticlient 6.0 installer, and that does work, and MRD will connect. Any suggestions?- thanks


Select Forum Responses to become Knowledge Articles!

Select the “Nominate to Knowledge Base” button to recommend a forum post to become a knowledge article.

Top Kudoed Authors