Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
mariusi
New Contributor

FortiClient VPN: client certificate (encrypted) selection no longer working after upgrade to 7.0.9

I had 7.0.3 and updated to latest FortiClient. Windows is 11 Version 22H2.

And now I can't see any certificates to select. Note: all my certificates are encrypted (a.i. have key symbol in User Certificates management).

I tried the suggestion from https://community.fortinet.com/t5/Support-Forum/FortiClient-VPN-7-0-8-NOT-showing-machine-certificat... without luck.

Tried to reinstall the certificate.

Made sure it's on the local account.

If I leave it to prompt for certificate, I get no prompt on login attempt.

 

Windows 10 retest: only simple unencrypted certificates are displayed in the selector.

 

The latest version(s) seems to have lost the ability to read such certificates

 

 

Any other ideas ?

3 REPLIES 3
mariusi
New Contributor

I have a 2nd connection possibility, meaning using Azure MFA and that does the login in browser. In it, it has enough rights to read the certificate, so I can login like that.

Would be nice if I find what is suddenly wrong with the rights of the FortiClient VPN.

My Windows user (MS account) is a local admin already.

mle2802
Staff
Staff

Hi @mariusi,
Is it happen with Win 11 only? Can you try 7.0.9 on Win 10 and see if the behavior is the same?

Regards,
Minh

mariusi

I have another PC with Win10.

Tried on it now. Some certificates are available for selection there, but only certificates without a key are displayed (from all that I see under the Personal folder in Manage User Certificates).

This matches the behaviour in the Win11 machine where I only have encrypted certicates, so none is displayed.

So not related to Windows version as far as I see.

I guess the 7.0.8/9 version lost the ability to read this kind of certificates.

Top Kudoed Authors