Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
New Contributor

FortiClient VPN Save Login

AnyConnect allowed us to prepopulate the username field and still require the user to enter a password when they are ready to connect to VPN.


With FortiEMS, I found that if we enable the "Allow personal VPN" option, you then have the option to save login and provide a username to a new connection you setup in FortiClient. However, the connection we created in EMS will have everything grayed out and not allow to save the username.


I tried enabling the "Show VPN Before Login" and "Use Windows Credentials" option, but you are forced to either use VPN prior to login or not. If you choose not to, then it does not cache your credentials when you are ready to connect.


Hopefully that makes sense. Does anyone know if there is a way to prepopulate the username field or store it without the end user having to setup their own VPN connections?

1 Solution

Not sure if this is relevant in recent firmware but may help?

View solution in original post


Not sure if this is relevant in recent firmware but may help?


Thank you for the reply Robert! I have seen those options available in EMS. The only problem with those options are that we don't want users storing their passwords for the VPN, just their username.


Hi I am looking at the same issue right now in that the profiles pushed out via EMS do not allow the username to be cached/saved. Did you ever find a resolution?

Thanks, Mark


Hi! I never found a solution. Still requiring users to enter both username and password. We are testing the Windows 10 FortiClient app that you can get from the Microsoft store. Hoping that will have an option eventually. 


I have also been looking at this as we need our employees to have their username save in the profiles pushed out via EMS,  the XML reference guide has the option


Changing <save_username> to 1


My EMS XML config shows <save_username>1</save_username> yet still doesn't save username. Anyone able to get this going in the last 6 years?


In client version, both options, i.e. save_username and show_remember_password, work. You just need to edit them in the XML configuration. Openly in the EMS panel, Remote Access Profile, even in the Advanced version, these options are hidden. For me it's completely **bleep** that there weren't such obvious options in the Advanced section.


Best regards


Select Forum Responses to become Knowledge Articles!

Select the “Nominate to Knowledge Base” button to recommend a forum post to become a knowledge article.

Top Kudoed Authors