Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
New Contributor II

Firmware upgrade problem 60F

Hi there!

I'm having some difficulties updating the firmware on a 60F unit.

I have a cluster of two, one of then (secondary) passed the upgrade with no issues (6.4.9 to 7.0.6), but the primary is giving me the error "Image upgrade failed. Firmware image is not valid".


I tried through web ui, I downloaded the image file and tried manually, and also tried though the Fortigate Cloud, with no success.


Any suggestions?

Thank you.

Carlos Almeida
Carlos Almeida

If that consistent, one side doesn't have any problem, which the other side never succeed, I would suspect something to do with the hardware, or state of hardware.

I would definitely open a ticket at TAC to get it examined.




Thank you @Toshi_Esumi  for you answer.

Could be the checksum difference between the units after the secondary update?

Carlos Almeida
Carlos Almeida

Are you saying they were not in sync before start upgrading the cluster? I would fix the sync problem before starting the upgrade.
But I don't think that would cause "image not valid".




Good Day,

Thank you for using the Community Forum. 


Please make sure to backup your current config file.

Please download the following upgrade file from on your desktop. Click on [Update] beside Firmware version under System Information widget when you click on Dashboard in GUI and browse to the downloaded file.

Kindly check if the HA status are in sync under System-->HA

The cluster units can see each other?
How the Heartbeat interface connected? If is there any switch in between? 

If the HA is out of sync , kindly do the following during the maintenance window to fix the sync issue :


For the synch issue with your ha cluster, the most reliable way to make sure everything syncs back together is the following.

disconnect the secondary unit (all wires)
perform a factory reset (exe factoryreset)
Backup config file from master
restore the config from the primary unit on the secondary.
from the cli, change the hostname

config system global
set hostname xxxxxx

change ha priority lower than the master

config system ha
set priority xxx

shutdown the unit
exe shutdown

re-attach ha heartbeat cables only
turn on the device and wait 5 minutes.
re-attach remaining cables.

This will ensure the proper config file is on both devices and they will sync. It will also ensure no network disruptions.


Kindly let me know, how it goes.





Hi @sferoz,

I'll give it a try. 
Thank you for your help. 


Carlos Almeida
Carlos Almeida

Select Forum Responses to become Knowledge Articles!

Select the “Nominate to Knowledge Base” button to recommend a forum post to become a knowledge article.

Top Kudoed Authors