Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
New Contributor

Captive portal attached to an interface but after authentication browser go loop

Hi all,

 I have attached a Captive Portal to my lan interface with a local group authentication.


From a pc client, when I open the browser for digit any website, the Fortinet login appear (correct)


I insert my username and password (correct)


Fortigate accept my credentials because I can see my user from "Monitor" -> "Firewall User Monitor" (correct)


the problem is now because in address bar of the browser, I can see a continuous loop of the address:







and the website that I asked don't open.


Also if I open another tab in Chrome, I can see the same loop with the magic token that change continually.


Can I solve or debug this big problem?


I haven't found any documentation about diagnostic of Captive Portal feature.











1 Solution

Hi guys.


I've fixed it with the following:


config user setting set auth-src-mac disable end


I think that by default Fortigate will also check on the mac address of the client trying to authenticate and if the client is behind a router before reaching the firewall the loop is the behavior we'll see. That setting above disables it.

View solution in original post


Hi all,

just wanted to give you an update on my case. Entering the mentioned command solved the issue for us. 

Special thanks to thende!



Hi everyone,


I just found this thread and thought that this could help me because my situation is a little similar.


My problem is that my browser got loop at, where there are no changes about MAC at the end, while I was trying to redirect the captive portal to a facebook page.


However, there was only one computer, the FIRST ONE to connect, could access the fanpage without any troubles, other devices after that met the looping problem above.


The solution thende gave was wondeful, I can learn from it, but I just wonder if it works for my case.


Sorry for my bad English


Best regards,




I used this setting to fix an issue on a firewall after upgrading to 6.2.2. It worked.


I have just upgraded a different firewall to 6.2.3 and this fix no longer works. I still get the error "redirected you too many times". 


I only experience this issue when I am on a subnet directly attached to the firewall. If I am on a remote subnet then I do not have this issue. Is anyone else on 6.2.3 experiencing this?


You probably have 2 gateways on your subnet and FGT is not your default gateway but FGT is the default gateway of your default gateway, being all together on the same subnet.

If this is the case I think it is a bad design and should be repaired instead of trying to find a workaround in this ugly picture.

In case you cannot fix it for some reason, make FGT your default GW and the second GW as a route to your internal networks, this should fix the issue.

Top Kudoed Authors