Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
lobo0621
New Contributor

Can't open console Forticlient VPN 7.4 In Sonoma

 

Hello everyone,

I recently upgraded from FortiClient VPN 7.2 to FortiClient VPN 7.4 on macOS Sonoma. However, I'm encountering a persistent issue where the application crashes immediately after briefly displaying the console screen. I've attempted reinstalling and deleting the /Library/Application Support/Fortinet/ directory, but the problem persists.

Below is an excerpt from the crash report:

 

 

 

 

 

Process:               FortiClient [1711]
Path:                  /Applications/FortiClient.app/Contents/MacOS/FortiClient
Identifier:            com.fortinet.FortiClient
Version:               7.4.0.1645 (???)
Code Type:             ARM-64 (Native)
Parent Process:        launchd [1]
User ID:               501

Date/Time:             2024-06-21 17:08:15.2847 +0900
OS Version:            macOS 14.5 (23F79)
Report Version:        12
Anonymous UUID:        211D612A-2605-BAE2-689D-2447A5CCDB76

...

Termination Reason:    Namespace SIGNAL, Code 5 Trace/BPT trap: 5
Terminating Process:   exc handler [1711]

Application Specific Backtrace 0:
0   CoreFoundation                      0x0000000191a2f2ec __exceptionPreprocess + 176
1   libobjc.A.dylib                     0x0000000191516788 objc_exception_throw + 60
2   CoreFoundation                      0x0000000191963aac -[__NSSingleObjectArrayI objectAtIndex:] + 308
3   guimessenger_jyp.node               0x0000000109b4a34c _ZN13MessageSender12GetECDetailsERKN4Napi12CallbackInfoE + 264
4   guimessenger_jyp.node               0x0000000109b644ac _ZN4Napi12InstanceWrapI13MessageSenderE29InstanceMethodCallbackWrapperEP10napi_env__P20napi_callback_info__ + 84
5   Electron Framework                  0x00000001136975c8 napi_is_detached_arraybuffer + 224

 

 

 

 

If anyone has experienced a similar issue or has insights into troubleshooting this, I would greatly appreciate your advice.

Thank you in advance!

 

1 REPLY 1
Simo5629
New Contributor

I had the same error with 7.4. When I downgraded to 7.2, it worked fine, so I think it is an issue with 7.4. Until this bug is fixed, I would suggest using 7.2.

Announcements

Select Forum Responses to become Knowledge Articles!

Select the “Nominate to Knowledge Base” button to recommend a forum post to become a knowledge article.

Labels
Top Kudoed Authors