Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
dan
Contributor

Can't get Fortigate 7.0.5 VM to run on eval license

To check the 7.0.5 release in a test environment, I downloaded the image

FGT_VM64_KVM-v7.0.5-build0304-FORTINET.out.kvm

and added it to GNS3. I've done this plenty of times. The image will run a couple of days in eval mode and I can then exec factoryreset to reset the eval timer. 

Works fine in a simulation environment like GNS3.

 

However, I seem to have an issue, as the eval license is not working anymore. 

 

Each time I spin up the image, I am greeted with the following after a few seconds :

"*ATTENTION*: Admin sessions removed because license registration status changed to 'INVALID'"

 

and, surely it shows:

FortiGate-VM64-KVM # diag debug vm-print-license
SerialNumber: FGVMEVX0OGFYAC9A
CreateDate: Thu Feb 10 08:20:15 2022
Evaluation license expires: Wed Dec 31 16:00:01 1969
Model: EVAL (1)
CPU: 1
MEM: 2048
VDOM license:
permanent: 1
subscription: 0

 

 

usually exec factoryreset or exec factoryreset2 would to the job.

Or downloading a new copy of the image. But this time I seem not to be able to get a decent eval time. 

 

Anyone has an idea?

 

Thanks

Dan

 


System is starting...
Starting system maintenance...
Starting log partition maintenance...
Scanning /dev/vdb1... (100%)
Serial number is FGVMEVX0OGFYAC9A


FortiGate-VM64-KVM login: admin
Password:
Login incorrect


FortiGate-VM64-KVM login: admin
Password:
Welcome!

FortiGate-VM64-KVM # get sys status
Version: FortiGate-VM64-KVM v7.0.5,build0304,220208 (GA)
Virus-DB: 1.00000(2018-04-09 18:07)
Extended DB: 1.00000(2018-04-09 18:07)
Extreme DB: 1.00000(2018-04-09 18:07)
AV AI/ML Model: 0.00000(2001-01-01 00:00)
IPS-DB: 6.00741(2015-12-01 02:30)
IPS-ETDB: 6.00741(2015-12-01 02:30)
APP-DB: 6.00741(2015-12-01 02:30)
INDUSTRIAL-DB: 6.00741(2015-12-01 02:30)
IPS Malicious URL Database: 1.00001(2015-01-01 01:01)
Serial-Number: FGVMEVX0OGFYAC9A
License Status: Valid
Evaluation License Expires: Fri Feb 25 08:33:54 2022
VM Resources: 1 CPU/1 allowed, 997 MB RAM/2048 MB allowed
Log hard disk: Available
Hostname: FortiGate-VM64-KVM
Operation Mode: NAT
Current virtual domain: root
Max number of virtual domains: 1
Virtual domains status: 1 in NAT mode, 0 in TP mode
Virtual domain configuration: disable
FIPS-CC mode: disable
Current HA mode: standalone
Branch point: 0304
--More-- *ATTENTION*: Admin sessions removed because license registration status changed to 'INVALID'
exit


FortiGate-VM64-KVM login: admin
Password:
Welcome!

FortiGate-VM64-KVM # diag debug vm-print-license
SerialNumber: FGVMEVX0OGFYAC9A
CreateDate: Thu Feb 10 08:33:54 2022
Evaluation license expires: Wed Dec 31 16:00:01 1969
Model: EVAL (1)
CPU: 1
MEM: 2048
VDOM license:
permanent: 1
subscription: 0

FortiGate-VM64-KVM #

 

1 Solution
dan
Contributor

I found the issue. I realized that I did set up the GNS3 VM from scratch and missed one point. 

 

I noticed that the problem only occured when in a simulation, I had port1 connected to the "outside world" (meaning to the internet via the GNS3 cloud device). Some additional searching in this forum showed that it might be a time (ntp) problem.

 

Finally I found that ESXi was configured to set the GNS3 VM time and subsequently fiddled around with the Fortigate VM time within the GNS3 project.

 

Solution is to disable automatic timesync between host and GNS3 VM. 

 

dan_0-1644510956804.png

 

Dan

 

View solution in original post

1 REPLY 1
dan
Contributor

I found the issue. I realized that I did set up the GNS3 VM from scratch and missed one point. 

 

I noticed that the problem only occured when in a simulation, I had port1 connected to the "outside world" (meaning to the internet via the GNS3 cloud device). Some additional searching in this forum showed that it might be a time (ntp) problem.

 

Finally I found that ESXi was configured to set the GNS3 VM time and subsequently fiddled around with the Fortigate VM time within the GNS3 project.

 

Solution is to disable automatic timesync between host and GNS3 VM. 

 

dan_0-1644510956804.png

 

Dan

 

Announcements

Select Forum Responses to become Knowledge Articles!

Select the “Nominate to Knowledge Base” button to recommend a forum post to become a knowledge article.

Labels
Top Kudoed Authors