Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
New Contributor II

Azure SAML WiFi Authentication Cert Trust Error

I was following the guide to setup WiFi authentication using Azure and SAML IdP from the Fortinet community here 


The authentication does work, but it gives a certificate error when connecting. If you trust the cert the authentication goes through and works. The below error message is seen when using the Fortinet Factory cert.


Azure-SAML-Fortinet-Cert (2).png


The following error is observed when using a CA cert from Let's Encrypt.



The intended use is for this network to be used for personal cell phones of company employees. So I do not want employees to have download or trust anything on their devices when connecting to the network.


If it is not possible to avoid the cert trust error please let me know. Otherwise below is what I have tried to get it to work.


The documentation mentions using a CA certificate and redirecting the auth portal page. However, whenever I redirect the portal it breaks the authentication. I have tired adding the redirection in both the GUI and CLI and various certs, neither works.


Based on the error it seems that the cert error is occurring because the authentication request is coming from the internal IP of the subnet and not the FQDN of the cert. However as mentioned anytime I redirect the portal page it breaks the authentication. (Yes, I updated the Azure App and Fortinet URL's to reflect the redirected address, but it still broke the authentication).


I am still pretty new to certs and stuff so I am probably missing something and help is appreciated.






The certificate you are using cannot be verified, i see that you are using the IP instead of FQDN, maybe IP is not added as SAN(Subject Alternative Name).
For unmanaged devices you should use public certificate authorities (for example GlobalSign, Gigicert ... ) to avoid Cert warning.
Please review the following articles:


- Happy to help, hit like and accept the solution -
New Contributor II

To get the certificate to be seen as valid I had to setup the local DNS server on the Fortigate and enable it on the interface for the network where I want the certificate to be valid.

New Contributor

Im having same issue, could u please explain more datailed what you did?

New Contributor II

On the Fortigate I created a new recursive DNS service on the interface where I need users to authenticate using SAML. Then I created a new DNS database. I called the DNS Zone "Internal Domains" as the name. For the Domain Name I set it to the same domain as certificate uses.


Next I created DNS A record entry pointing to the IP of the firewall on the same vlan as the DNS server I created earlier.


For example, if the certificate you were planning to use is on a subnet of with the router IP of I would configure the DNS as follows:


Create a new DNS database with Domain Name of on the interface that has the subnet. I would then create a DNS A record of saml pointing to the IP of Finally on the interface set the DNS server to be same as interface IP. This will set the DNS server IP sent to DHCP clients as the Fortigate itself.

Now when you are prompted to do SAML auth the IP address matches the certificate, and it doesn't throw the error.




It worked! thank you so much

Top Kudoed Authors