Fortinet Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
New Contributor II

What are "flags" in "diagnose ipv6 address list"?

While tracking down some IPv6 issues, I have been unable to find the meaning of the "flags" field in output from the diagnose ipv6 address list command.  All three of my VLANs worked fine on IPv6, but this morning one of them wasn't. Huh? Policy ws right, sniffer shows the traffic hitting the inside interface, but not leaving.


I noticed that the "good" interface had flag=P on the interface's IPv6 address, but the "bad" one had just flag=<nothing>


Hmm. I bounced the interface, IPv6 address stayed the same but the flag turned to P and it worked now. Same thing on another interface.


A couple of hours of searching brought up exactly zero about how to read this output, though I suspect it's similar to some common Linux command or something.


FG # diagnose ipv6 address list dev= 5 devname=wan1     flag=P scope=0 prefix=128 addr=2605:e000:3fc0:38:d0e6:3741:4206:cf08 preferred=4294967295 valid=4294967295 cstamp=9148 tstamp=9148 dev=30 devname=VL1-HOME flag=P scope=0 prefix=64  addr=2603:8001:4101:b301::1                preferred=4294967295 valid=4294967295 cstamp=2341997 tstamp=2341999 dev=22 devname=VL6-WORK flag=  scope=0 prefix=64  addr=2603:8001:4101:b306::1                preferred=272112 valid=272112 cstamp=9148 tstamp=9148 dev=23 devname=VL8-IOT  flag=  scope=0 prefix=64  addr=2603:8001:4101:b308::1                preferred=272112 valid=272112 cstamp=9148 tstamp=9148


Sorry for blowing out the margins; this shows just the public-y addresses: wan1 is a /128 I get from my ISP, then the others are delegated from a /56 the provider handed me.  In this listing, VL1-HOME works (via and the other two don't.


I'd love to find out what this flag means, what causes it to change state, and what to look at in my configuration to make it settle down. Finding what the other fields mean would be helpful also.


Running a new FG60F running FortiOS7

New Contributor II

Hmm. This morning I rebooted the whole unit, all IPv6 works, but those addresses show up as flags=<none>.


I'd still love to know what those fields mean, or if this just proxies some underlying Linux networking command, that would work also.