Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
New Contributor II

forticlient vpn Error find interface for local_gwy 0186d40a

I am having problems with my vpn connection with forticlient.
the application makes the connection correctly, but once connected, my pc loses connection with the internet and with the server.
the version of forticlient vpn is and my s.o windows 11.
Checking the logs I found the following errors.
Error find interface for local_gwy 0186d40a
Did not find interface for local_gwy 0786d40a
msg="SSLVPN tunnel connection failed"
I have tried reinstalling the application, installing several different versions, even formatting the pc, but the problem persists.
As a curiosity, if I try from another pc with my user, the connection works perfectly, but on my pc, even if I try with different users, it still fails.
I appreciate any idea that can help me to solve this problem.

New Contributor II



I have more information, I have seen the following errors in the log:


31/01/2023 13:42:44 info sslvpn FortiSslvpn: 18720: fortissl_connect: device=ftvnic
31/01/2023 13:43:16 info sslvpn FortiSslvpn: 6836: PreferDtlsTunnel=1
31/01/2023 13:43:19 error sslvpn FortiSslvpn: 2532: error: poll_send_ssl ->SSL_get_error(): 5, try:1
31/01/2023 13:43:19 error sslvpn FortiSslvpn: 2532: error: poll_send_ssl -> WSAGetLastError():2746, try:1
31/01/2023 13:43:19 error sslvpn FortiSslvpn: 2532: error: poll_send_ssl ->data size: 66, try:1
31/01/2023 13:43:19 error sslvpn FortiSslvpn: 2532: [handle_driver_read_event]: error: poll_send
31/01/2023 13:43:19 error sslvpn FortiSslvpn: 18308: error: poll_recv_ssl -> SSL_get_error(): 5
31/01/2023 13:43:19 error sslvpn FortiSslvpn: 18308: error: poll_recv_ssl -> WSAGetLastError():2746
31/01/2023 13:43:19 info sslvpn FortiSslvpn: 18308: error: polling recv, try:1
31/01/2023 13:43:23 info sslvpn FortiSslvpn: 16164: Ras: connection to fortissl terminated

New Contributor II

Have the same issue wit a Consultant PC Windows 11 7.0.7 and 7.2.0 Fre VPN Client. What I have seen or find out additionally. Firewall is not getting any Packet from the assigned IP Address. The internal DNS Servers are added but not the IP address we stay with Adapter shows Network indentifying for ever because of missing IP Address. On Firewall side all looks good.


From another Post (Windows 11 22H2 update, FortiClient VPN doesn't work):

James Morales: I have been researching and digging into this for a while and stumbled on the solution you need to uninstall (KB2693643), just did it on my machine and FortiClient connected with no issue.

Former Post with workaround:

I have this same issue, the VPN connects just fine but the IP never updates and using the work around to manually configure the Network connections is the only way to get it to work.  There is no issue with the network, I have tried in numerous locations and it seems to be consistent with just the one PC with Windows 11.  Everyone else in the company has no issues connecting to the VPN.  Everything is configured properly so its not network, in an effort to try and figure out if its an issue with my profile I reinstalled windows 11 and the issue remains. 

New Contributor II

In my case, the problem was an update to windows 11. To solve it I had no choice to reinstall the computer with windows 10, and everything worked again.

New Contributor II

carloseqt443 which update affects the client? I thought alo it could be a Windows update, but my Consultant said it starts 2 days ago. i checked his update history and the last update was from mid of February. Thanks Ralf

New Contributor II

The problem in my case was a windows update. I had problems with several forticlient clients and all of them had the same problem.
I couldn't tell you specifically which windows update caused the problem, only that when I upgraded to windows 10, the computer worked without any problem.

New Contributor II

Thanks for quick response! I appreciate it. Thanks, Ralf

New Contributor

I'm having the same issue here, been fighting with it all day. Interestingly though I have two identical builds (except specific device drivers) Both Win 11 22H2 and one connects and works fine the other doesn't.


With the failing machine I set a ping going to ping my DC. When I connected the SSL Vpn the ping replied for a few seconds then stopped. If I leave it connected it will on occasion reply. On a couple of occasions it would reply for a large period of time before failing again.


I've tried the following.


Disabled all IPv6 in all networking devices.

Re-installed Forticlient

Uninstalled and installed the VPN only version

Tried a different wifi connection

Uninstalled all windows updates

Uninstalled my RSAT tools

KB2693643 isn't installed on my machine so couldn't try that.

So now i'm facing the prospect of having to re-image the machine which I really don't want to do.


Checked the logs and I see the "Did not find interface for local_gwy 0786d40a" entry as well.


I would appreciate it if anyone has any further experience with this issue.

New Contributor

just to add something, I've done some further testing and although it wasn't that easy for me to do i managed to test it on a wired connection. On a wired connection the VPN is stable. So i'm leaning towards the Wifi driver. For the record its an Intel AX211


Did you ever get this working?  I am having the same issue on the same hardware.


Select Forum Responses to become Knowledge Articles!

Select the “Nominate to Knowledge Base” button to recommend a forum post to become a knowledge article.

Top Kudoed Authors