Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
New Contributor

How to fix DNS-Settings after Forticlient 6.2 connects over sslvpn on OSX Mojave

Hello everyone,

after working for month with an older version of Forticlient with a "fix-dns"-script (mainly using scutil to add new ServerAddresses to name lookup), the newer version of Forticlient keeps on disconnecting me, when executing the very same script which worked before. I tried a little bit back and forth, but could not find a solution on my own.


My Script which worked perfectly before


scutil <<EOF
 d.add ServerAddresses <the vpn dns server ip-address>
 set State:/Network/Service/forticlientsslvpn/DNS


After connecting to my destination vpn, the script was executed with root privileges. I could ping e.g. and it worked. Because of some unfortunate circumstances I had to install the new forticlient 6.2. After that, the script did not work anymore. So I tried to find an older version: After uninstalling 6.2 and re-installing 6.0.6, still my dns-fixing script does not work anymore.


Then I tried doing the steps manually. I could see, that my script did not change the dns settings anymore. In conclusion I did the steps manually and as soon as I use the command "set State:/Network/Service/forticlientsslvpn/DNS" my fortclient drops the connectoin with the message "The VPN connection terminates unexpectedly! (Error Code: -113)"


It would be great if someone can help me. Maybe there is a way to add different configurations.

Many thanks in advance