Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
New Contributor II

Forticlient Blank Screen on Fedora Linux


I am obligated to use Forticlient VPN for my workplace. Unfortunately, whenever I try to open the Forticlient GUI, I get a completely blank screen. The navigation menu on the top loads fine, I can press file which gives me an option to quit the application (and nothing else), and I can press Help which gives me two links to documentation that don't help me in this situation. The program itself doesn't load however.

Does anyone have an idea how to solve this issue? I just tried to install the rpm-package from the VPN-only client. I guess it may be specifically designed for CentOS only? If so, is there any way to get it working on Fedora?


My terminal output doesn't give me a lot:
[sjoerd@lennart ~]$ forticlient
Fontconfig warning: "/usr/share/fontconfig/conf.avail/05-reset-dirs-sample.conf", line 6: unknown element "reset-dirs"
Platform detected: fedora
[ '/usr/lib/opt/forticlient/gui/FortiClient-linux-x64/FortiClient' ]

I'm running Fedora Silverblue with the latest base image from the 3th of June 2022 if that helps anyone.

Kind regards,

Honored Contributor

as far as  I read now that is not a problem with forticlient but more some bug in the fontconfig package shipped with fedora. 

There is entries in their bugtracker: 


I did not yet find a workaround except from (prolly manually) update fontconfig.


At least that's the only warning or errror that is shown in your quote. 

CentOS/Fedora/Redhat should be compatible though...


"It is a mistake to think you can solve any major problems just with potatoes." - Douglas Adams

-- "It is a mistake to think you can solve any major problems just with potatoes." - Douglas Adams
New Contributor II

Thank you for the reply, that gives me at least a hint of where to look for a further solution. I will report back if I manage to fix it by fiddling with fontconfig!

Honored Contributor

the fontconfig message thus is just a warning. So it might not be the actual reason...

You could try to execute 'strace forticlient' to see what it does and opens etc.

(you might first have to install strace).

the strace will give you a load of information so you will have to have a closer look...


"It is a mistake to think you can solve any major problems just with potatoes." - Douglas Adams

-- "It is a mistake to think you can solve any major problems just with potatoes." - Douglas Adams
New Contributor II

Check that fortivpn service is running and directory /var/lib/forticlient exists

New Contributor II

So I just reinstalled Forticlient to check this, and bingo... this directory does not exist at all. Not sure if it should, it still exists in /var/opt/forticlient. But nothing in /var/lib. I'm pretty sure the main issue has something to do with the immutable nature of Silverblue, since it works fine on Workstation.

Maybe I'll check if Fortinet has some feedback/issue tracker for general development just to notify them that this issue exists. But otherwise I think it's a bit of a dead end at the moment.

New Contributor II

Tested on FC32, FC35, FC36 and FC37. - Seeing the same, and some observations in differences between deb and rpm is that '/usr/bin/forticlient -> /opt/forticlient/forticlient-cli' is lacking on Fedora.  Maybe /opt/forticlient/fortivpn is the same as forticlient-cli on Ubuntu/Debian.


If I start 'FortiClient gui' manually


$ /opt/forticlient/gui/FortiClient-linux-x64/FortiClient gui
Platform detected: fedora 1
22:40:00.616 › Platform detected: fedora
[ '/opt/forticlient/gui/FortiClient-linux-x64/FortiClient' ] 1
22:40:00.619 › [ '/opt/forticlient/gui/FortiClient-linux-x64/FortiClient' ]
Saml - init 1
22:40:00.660 › Saml - init
compliance configDir=/home/user1/.config/FortiClient/config 1
22:40:01.226 › compliance configDir=/home/user1/.config/FortiClient/config
did-finish-load 1
22:40:01.230 › did-finish-load
ready-to-show 1
22:40:01.232 › ready-to-show


   and then I get a white blank screen. 


   How about doing some simple QC before shipping your software?  Any suggestions are appreciated. 


- Tested on "baremetal" installs of FC37

- xfs (fontserver is running), font-manager works

- forticlient.service is running

- directory /var/log/forticlient/ exists and logs present

- Using X11 w/Wayland support

- 'ldd FortiClient' show all libraries resolves

- Tested, and  

- inxi X11 config:
   Display: x11 server: X.Org v: 1.20.14 with: Xwayland v: 22.1.8
compositor: gnome-shell driver: X: loaded: modesetting,nvidia
unloaded: fbdev,nouveau,vesa alternate: nv dri: iris gpu: i915
display-ID: :1.0 screens: 1
Screen-1: 0 s-res: 7680x2160 s-dpi: 96
Monitor-1: DP-1 mapped: DP-1-1 pos: left model: Dell U2720Q res: 3840x2160
dpi: 163 diag: 685mm (27")
Monitor-2: eDP-1 mapped: eDP-1-1 pos: primary,right model: Sharp 0x148d
res: 3840x2160 dpi: 284 diag: 395mm (15.5")
API: OpenGL v: 4.6.0 NVIDIA 530.30.02 renderer: Quadro P2000/PCIe/SSE2
direct-render: Yes


      I want to decommission the Aruba VPN controller, but as long as the forticlient isn't on par  with the Aruba VIA VPN client on all platforms (Android, IOS, MacOSX, Linux (deb/rpm) and Windows), that's not happening.  



New Contributor II

It's very interesting that it's not working for  you though, as I think our underlying issues are different in nature (unless your GNOME machine is Silverblue as well).

Overall poor QC when shipping software is a thing I notice more often, and I sometimes seriously doubt if they ever tested their software even once on anything else than their own dev system. Not just with Linux applications, but in general. I've got popular (>1M downloads) apps on my iPhone that are so painstakingly broken, even though iOS is like the most predictable system out there (barely any hardware variance, almost all people use the latest version). It's honestly baffling sometimes.

New Contributor II

Some progress. forticlient- finally works on FC37 with the latest updates and Mate 1.26.1 window manager.

On my main machine with Gnome 43.3, it still does not.  

New Contributor II

To comment on this, as I see I never reported back on this (to be fair, I said I'd report back if I'd manage to set things up, I didn't).

I found Forticlient works "fine" for me on Fedora 37 Workstation (both on GNOME as DE, and I also tried on the KDE spin in a virtual machine). I run Fedora Silverblue on my personal laptop however, and it is there it is having these issues.

So it is compatible enough with Fedora itself. However, it has difficulties with the immutable filesystem from Fedora Silverblue. It's been a while since I've looked into this in detail, but I think vovan might be on to something and it might have issues with creating a valid folder in /var/forticlient.

Unfortunately this is not something I've been able to resolve, other than using a VM for my forticlient VPN needs, and it may need some fundemental changes to the client's code to fix this (just guessing) while only a very small subset of the overall market uses immutable Linux distro's. Personally I believe it's the future, so maybe at one point it will be properly supported, but as of right now (March 2023) I don't think it's possible to run Forticlient on Fedora Silverblue.

Top Kudoed Authors