Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
New Contributor III

FortiGate won't let standalone switch be a standalone

New to Fortinet, so please bear with me.


I have a new Forti network environment managed by a FortiGate (7.0.12) and have trouble setting up a standalone switch (7.4). I do not want this switch managed by the FG at all. When I initially set up this switch, I set it up as managed, but when I realized that configuration wouldn't work I set it up as a standalone. This switch does appear in in FG managed Fortiswitches.


Each time I connect this switch to its uplink, that port goes from displaying my native vlan to displaying the name of the switch. (The native vlan is not set to data.fortilink.) When I hover over the name it shows "Dedicated to connect to peer FortiSwitch." I can't ping the switch once connected to the network. After disconnecting the uplink and waiting for a few minutes, the native vlan changes from switch name back to my original native vlan.


I've tried resetting via the recessed button several times, all to no avail. When I configure as standalone, the switch is not uplinked. Only afterward do I uplink and then the port change happens.


I assume this happens because I originally set up this switch as managed, and for some reason it won't let go. I ran across this:

I tried the suggested command: execute switch-controller switch-action set-standalone <switch-id>

The problem is, switch-action is not available. Nor is execute switch switch-action available.


All I need is a basic, standalone switch.

Any help is greatly appreciated.

1 Solution

Have a look here :

Converting to FortiSwitch Standalone

If you have found a solution, please like and accept it to make it easily accessible for others.

View solution in original post

New Contributor III

Yes, this worked great. Thank you!

For anyone reading this in the future, here are the approximate steps I took to resolve this issue...

  1. Uplinked the switch I wanted configured as a standalone.
  2. My FG sees this switch and adopts/authorizes.
  3. Deauthorize and delete this switch from the FG.
  4. Ran the command above from the FG.
  5. Disconnect the switch.
  6. Factory reset the switch. I know that the command is supposed to do this, but I could not access on the recovery IP until I reset this switch.
  7. Configure as needed.
  8. Uplink the standalone switch to a port that is NOT set up as a Fortilink port and where the LLDP profile is set to access.
Top Kudoed Authors