Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
XFox
New Contributor II

FortiClient VPN Console takes a very long time to open on Mac (macOS Ventura and Sonoma)

On my Mac it takes a very long time, about 2 minutes, for the FortiClient Console to open.

When I click on the FortiClient menu bar icon --> Open FortiClient Console, the FortiClient app starts bouncing in the Dock for about 1 minute, then an empty FortiClient window appears and after another minute the GUI elements appear and the Console becomes usable.

Is anyone experiencing the same issue?

 

System configuration:

  • MacBook Air (M1, 2020)
  • macOS Ventura 13.5 (22G5048d) Beta 3
  • FortiClient VPN 7.2.1.0718
13 REPLIES 13
Jean-Philippe_P
Moderator
Moderator

Hello XFox, 

 

Thank you for using the Community Forum. I will seek to get you an answer or help. We will reply to this thread with an update as soon as possible. 

 

Thanks, 

Jean-Philippe - Fortinet Community Team
Jean-Philippe_P
Moderator
Moderator

Hello,

 

We are still looking for an answer to your question.

 

We will come back to you ASAP.

 

 

Thanks,

Jean-Philippe - Fortinet Community Team
fatihseyligli

Hello,

 

Could you please follow the steps below to disable IPv6 on MacOS?

 

- Click on the Apple icon in the top left corner of your screen.

- Open System Preferences > Network.

- Select the network that you are already using.

 

Note: If you are connected to the internet wirelessly, the active adapter will be Wi-Fi. However, if you are connected via a LAN cable, the corresponding adapter will be Ethernet.

Click on the Advanced button.

 

- Next, click on the TCP/IP tab

- Select the Configure IPv6 drop-down menu and set it to Off.

- Click the OK button.

- Restart your Mac to make sure the IPv6 is disabled.

 

 

* You may not have the turn-off IPv6 option available. In this case, you need to run a command through the Terminal app:

 

Disable IPv6 from the command line:

 

 

- Open Launchpad.

- Search for Terminal.

- Click on the Terminal.app.

- If your active network is WiFi enter the following command:

 

networksetup -setv6off Wi-Fi

 

- If you are on Ethernet:

 

networksetup -setv6off Ethernet

 

- You may combine both commands to disable IPv6 on WiFi and Ethernet at the same time:

 

networksetup -setv6off Ethernet && networksetup -setv6off Wi-Fi

 

Please restart your Mac and recheck the console issue.

 

Regards.

XFox
New Contributor II

Hello,

please note that in the latest days the Console behaviour has worsened, prior to the tests and restarts described below the Console window started remaining completely empty and unusable when I tried to open it, even after several minutes.

 

On macOS Ventura there isn't the option to turn off IPv6 using the GUI so I used the networksetup shell command to disable it for both my active network services, Wi-Fi and Belkin USB-C LAN:

  • After turning IPv6 off and before restarting the Mac, I saw no difference in the FortiClient VPN Console behaviour (i.e. the Console window was always blank).
  • After turning IPv6 off and after restarting the Mac, the FortiClient VPN Console started to work fine again (i.e. I was able to open the Console window without issues or delays).
  • After turning IPv6 on again (-setv6automatic) and before restarting the Mac, I still could open the Console window without issues or delays.
  • After turning IPv6 on (-setv6automatic) again and after restarting the Mac, I still could open the Console window without issues or delays.

Since I'm unable to trigger the issue by enabling IPv6 again, I'm not sure what actually fixed the Console window: turning off IPv6, restarting the Mac or both.

However, I will keep an eye on the Console and I'll update this thread if the issue returns.

XFox
New Contributor II

Hi, I have an update about this issue.

 

The FortiClient Console on my Mac, now on macOS Ventura 13.5 (22G5059d) Beta 4, started taking a very long time (about 2 minutes) to open again.

This time I tried to restart the Mac without disabling IPv6 first and, after the reboot, the FortiClient Console started opening again quickly and without problems.

 

It seems to be a bug that only manifests itself after a few days of starting up the Mac.

Interestingly, I have a work colleague with the same software setup but on a Intel Mac (I have an Apple Silicon machine) and he is not experiencing the issue.

 

Do you have any suggestions?

I could try disabling IPv6 to see if the problem still occurs but that would just be a workaround.

Is there a way to report this issue directly to Fortinet even if we don't have access to technical support for the FortiClient VPN clients (we are using the "light" version without license)?

TobiK
New Contributor

Hi, any updates on that? Issue is still there with FC VPN 7.2.1 and macOS 14.

TobiK
New Contributor

Same with 7.2.2

joepdl
New Contributor

Came here for a solution, staying to upvote this issue. Exactly the same issue here and thus far disappointed by the lack of a response and no bugfix for months.

fatihseyligli

Hello,

 

Could you please enable Full Disk Access on your macOS?  

 

Please check:

 

https://docs2.fortinet.com/document/forticlient/7.2.2/macos-release-notes/223986/special-notices

 

Thanks & Regards 

 

Labels
Top Kudoed Authors