Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.

FortiAP disable bluetooth


is any way to disable bluetooth on 231F model?


Hey Tutek.  Have you tried removing the BLE profile from your FortiAP profile?  You may need to do this in the CLI. 

Secure all the things!

but as I can see none ble-profile is assigned:


FGT (FAP231F-default) # get
name                : FAP231F-default
comment             : 
    type                : 231F 
    ddscan              : enable 
control-message-offload: ebp-frame aeroscout-tag ap-list sta-list sta-cap-list stats aeroscout-mu sta-health spectral-analysis 
apcfg-profile       : 
ble-profile         : 

I don't believe it is active if there is no profile configured against it.  In testing against two of my lab FAPs, that is the behavior I can see.  If you do a "show" instead of "get" that would also confirm what is configured and active in the profile.  


Is there something that you are seeing to indicate that BLE is active?  

Secure all the things!

Do you see my first line in block code here is command "get" .

Bluetooth LED on the device is turned on all the time.


Yes, I do see that, and I see the same thing in my profile as get will show all the configurable options in the wtp-profile. Without a profile assigned, the feature shouldn't be enabled. 


I had a look at the QSG for your model ( could you confirm a couple of things? 


1. Which LEDs are blinking blue as per page 4 in the guide?  LED 4 will blink blue if only Radio 1 is in use. 

2. Confirming that the default profile is what is applied to the FAP? Have you tried creating your own profile and applied it to the FAP?

3. Could you post the full output of show for the profile with any personal info removed?  

4. Which FortiOS and FortiAP firmware versions are you using?

Secure all the things!


1.fifth led  - bluetooth is always on with amber colour

2. I have only one profile 


4.Fortigate is 6.4.9 and FortiAP FP231F-v7.0-build0034



Hi Tutek, 


As per the quick start guide (FAP-231F QSG) when LED 5 is orange it means that Radio 3 is turned on. In the case of the 231F, this would mean that the Dedicated Monitor has been enabled on radio 3.  If BLE was enabled with radio 3 it would be green.  Have a look inside your FAP-231F profile to verify that radio 3 is enabled.  


Based on that I'd say that BLE is not turned on. 



Screenshot 2022-11-14 081600.jpg

Screenshot 2022-11-14 081534.jpg


Secure all the things!

Hi Tutek,

We understand that you would like to disable bluetooth on the FortiAP. 

Could you please perform the following troubleshooting steps:


1. Could you please follow the compatibility matrix between FortiOS and FortiAP


2. If possible, test with the latest FortiAP version on the trunk, for example FortiAP Ver 7.0.5 
3. SSH to FGT CLI, execute the following command:

         diag wireless-controller wlac -c wtp bleprof

4. SSH to FAP CLI, execute the following command:


         cw_diag -c ble-config

5. Check if it is advertising bluetooth information

6. If it is still advertising bluetooth with no BLE profile configured

7. Try to change the BLE profile settings on the FortiGate and verify whether the correct settings are pushed to the FortiAP using the above mentioned commands

8. If none of the above steps helped, please open a ticket with Fortinet TAC so that it can be investigated further


Select Forum Responses to become Knowledge Articles!

Select the “Nominate to Knowledge Base” button to recommend a forum post to become a knowledge article.

Top Kudoed Authors