Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
TheNickster
New Contributor

Connecting Fortigate 200D to FortiSwitch 124D/248D with FortiLin- SFP connection required?

In reviewing the documentation (now that I already own the switches), it appears that I can only connect a 124D and 248D via their SFP ports if I want to leverage FortiLink (switch management via FortiGate).  The problem is...no SFP ports on the FortiGate 200D...Ethernet.  So I guess I need to order at least two FG-TRAN-GC units (at $100+ each)?  Anyone have experience with these?

7 REPLIES 7
rgracioli_FTNT

Hi,

 

Any port can be used for FortiLink, it's just that only the SFP ports are enabled for FortiLink by default. There are two options:

1. just enable the port you want on the cli with the following command:

config switch interface edit "port#" set dynamic-fortilink-mode enable next end

 

2. upgrade to version latest 3.3.2, in this release, the last four RJ45 ports are also enabled by default

 

The documentation is under revision to avoid the misunderstanding.

 

Thank you,

 

Rafael

 

 

Rafael Gracioli | Consulting Systems Engineer, ADC and Switching m: +31 6 50 28 72 99 | skype: rgracioli | e: rgracioli@fortinet.com

TheNickster

The results of the two options:

1) it doesn't like the command: set dynamic-fortilink-mode enable....responds with: command parse error before 'dynamic-fortilink-mode'  Command fail.  Return code -61

2) I am on v3.3.2,build0128,151026, and I can't get Port24 to resolve with the switch in Managed Mode :(

TheNickster

I'm thinking my FortiGate 200D (running 5.2.3) may not be seeing the 124D because it is not a supported model in that version of FortiGate.  

 

It does show up in the 5.2.4 release notes.

 

No idea what to do about the 248D...since it is so new :(

rgracioli_FTNT

apologies,

1. the command should be the following:

config switch interface edit "port#" set auto-discovery-fortilink enable next end

(the command I mentioned in the previous post is shown after the FortiSwitch changed to FortiLink mode)

 

2. as the version is already 3.3.2, then probably the configuration on the FortiGate side still needs to be done: enable "Dedicated to extension device" option in the interface to which the FortiSwitch is connected

after FortiSwitch is connected to the port, the switch can be authorized under "wifi and switch controller"

 

Regarding FS-248D, it requires FortiOS 5.4 for FortiLink to work.

Rafael Gracioli | Consulting Systems Engineer, ADC and Switching m: +31 6 50 28 72 99 | skype: rgracioli | e: rgracioli@fortinet.com

TheNickster

rgracioli_FTNT ,

 

Thanks so much for your help...we are getting closer :)  I was able to able to get the commands to take, switched the 124D to managed mode (reboots automatically), wireless and switch management enabled.  Connected to Port15 on the 200D, .  Port15 set 'Dedicated to extension device'...left the IP at the default for the moment.  I believe I should see the 124D under my Managed Devices under 'Wifi and Switch Controller'...but I do not :(

TheNickster

Updated to v5.2.4 of firmware.  No change.

amargys

Hi TheNickster,

 

Have you managed to get it working? I have the similar issue. Would be nice to know if you got it working.

 

Thanks.

Top Kudoed Authors