Support Forum
The Forums are a place to find answers on a range of Fortinet products from peers and product experts.
New Contributor

AirPrint Multicast in NAT mode

Hi everyone,

I recently installed a FortiGate 60E in my home network, that I share with few other people. For certain reasons, I don't have an administrative access to the home gateway, so I had to set my FGT in NAT mode. Everything's fine, but the other people in the house have to print on the HP printer that is in my network. So I tried setting up multicast policies, but nothing has worked until now.


The "outer" network is connected through WAN1, and its net address is

My network is The printer is connected to an airport extreme in bridge mode, which is connected to the internal FGT switch.

The multicast policies I set are basically two: one from to all the services (from WAN1 to Internal) and the other one from the printer ( to all the services (from Internal to WAN1).

Leaving all the security issues aside that I will think about later, I can't see from my network all the multicast devices that are on the outer network, like TVs, stereos...

I set up firewall policies that allow traffic between and the printer, but I'm not sure if the NAT should be allowed or not.

Thank you in advance


Did you allow mulicast forward on the system settings?

You can try and follow this guide:

- Toss a 'Like' to your fixxer, oh Valley of Plenty! and chose the solution, too00oo -

Hi Alex,

I followed that guide, and basically I had to enable all the protocols through the interfaces, and disable multicast routing (I already had multicast forward enabled).

The thing is, now that I can view the printer from the outer network, I try to print, but the communication between the device and the printer is stuck on "Printing" without any response from the printer. Do you know how can I solve this issue?



First see where the problem is - does the traffic pass both ways to/from the printer (run a packet capture) ? and if not, see why the FortiGate blocks them (debug flow)

- Toss a 'Like' to your fixxer, oh Valley of Plenty! and chose the solution, too00oo -

For me, this problem happens with smarthome products using different APs around the house. If they are not on the same AP (wifi router), the broadcast and multicast, even if allowed on the FortiGate, are filtered by the cheap wifi routers that I use as AP

- Toss a 'Like' to your fixxer, oh Valley of Plenty! and chose the solution, too00oo -

Thank you for your reply,

I tried to perform a packet capture, but everything seems alright. The debug doesn't give any explicit error, but seems stuck in a loop where the connection between the two devices succeed in establishing a connection.

I don't think that the APs are the problem: I tried connecting the printer to the net (which is covered by cisco APs instead of my Airport Extreme) and from every AP in the house, inside the same network, the printing succeeds.

Maybe it's because the two devices that need to establish a connection don't have the same gateway?


Select Forum Responses to become Knowledge Articles!

Select the “Nominate to Knowledge Base” button to recommend a forum post to become a knowledge article.

Top Kudoed Authors