FortiGate
FortiGate Next Generation Firewall utilizes purpose-built security processors and threat intelligence security services from FortiGuard labs to deliver top-rated protection and high performance, including encrypted traffic.
guptas
Staff
Staff
Article Id 194503

Description


This article describes the reason behind the Header message 'FortiGate time is out of sync' seen from the GUI even when the NTP status is synced.

 

Scope

 

FortiGate.

Solution


Simplify the date/time conversions by using standard IANA Time Zone Database names in order to display date/time in the browser in the correct display timezone.

Further simplified and streamlined how timezone offsets are calculated in the case that manual offset needs to be applied either for displaying a FortiGate string timestamp or saving one from the dialog.

UTC Timestamps will be able to be displayed as is, without any processing simply by using 'formatDateTime()' function from Neutrino/gui_shared.

Added a platform warning in the header to let the user know that the FortiGate time is out of sync with real time when manual time is set and it is off by more than two minutes.

17212023sdsd58153 - Copy.png
 
Hence, if the system time is set manually to reduce the time difference between the client system and FortiGate to below 2 minutes, it will remove the header message 'FortiGate time is out of sync' from the GUI. Check also whether the computer machine on which the FortiGate is being accessed is in the same time zone; if the computer machine time is different in the FortiGate set time zone, it will also show the time is out of sync.
 
When the system time is set to NTP, switching to manual and matching the 'Current system time' with the time in the computer will work as a temporary workaround, the time difference might reappear if the time is set back to NTP.
 
To verify the FortiGate's current system time via GUI, simply go to System -> Settings
 
system time.jpg

 

Or via CLI, using the command:
 
execute time
FGT # execute time
current time is: 14:50:17
last ntp sync:Mon Mar 24 14:44:30 2025
 

If the issue persists, run the below command to verify the NTP status and the servers it is updating: 

 

diagnose sys ntp status

diagnose debug reset
diagnose debug disable
diagnose debug console timestamp enable
diagnose debug application ntpd -1

diagnose debug enable 

diagnose debug disable  <----- To disable logging.

 

Root Cause:

This message is not based solely on NTP sync status. It appears when:

  • FortiGate system time differs by more than 2 minutes from the local client (browser) time.

  • FortiGate is manually set to a system time not aligned with the client's time zone or real-time clock.

  • Time zone differences between FortiGate and the accessing client may also cause this if not interpreted correctly by the browser.

Note:

A large time discrepancy could impact services, such as intermittent VPN connections, because certificates may appear expired and the FortiGate may be unable to contact the FortiGuard server. A power outage at the site could also cause the time to become misaligned. If the system current time and the computer time are already synced, try to refresh the browser and check again. This issue can occur after a firmware upgrade.

 

Related articles:

Technical Tip: Setting up an NTP server and an NTP client using two FortiGates

Technical Tip: Troubleshoot NTP synchronization issue

Technical Tip: Configuring a FortiGate unit as a NTP server